{"answers":{"affected":"2 open source packages ship an affected version, including bootstrap-sass. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-10842 in the wild and no public exploit code.","fix":"Upgrade bootstrap-sass to 3.2.0.4 or later.","what":"CVE-2019-10842 is a critical code injection vulnerability in n/a, published on 4 Apr 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-10842 and fix it if it is affected.\n\nWhat it is: CVE-2019-10842 is a critical code injection vulnerability in n/a, published on 4 Apr 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-10842 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- bootstrap-sass (RubyGems): affected from 3.2.0.3; fixed in 3.2.0.4\n- bootstrap-sass (RubyGems): affected from 3.2.0.3; fixed in 3.2.0.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-10842/ (Markdown: https://insights.sbomify.com/CVE-2019-10842/index.md)","id":"CVE-2019-10842","markdown":"https://insights.sbomify.com/CVE-2019-10842/index.md","name":"CVE-2019-10842","record":{"aliases":["GHSA-vqqv-v9m2-48p2"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby Sass library","requires_auth":"none","summary":"An attacker can execute arbitrary code on systems using the bootstrap-sass library by sending a maliciously crafted cookie value.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"bootstrap-sass","vendor":"getbootstrap"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"Arbitrary code execution (via backdoor code) was discovered in bootstrap-sass 3.2.0.3, when downloaded from rubygems.org. An unauthenticated attacker can craft the ___cfduid cookie value with base64 arbitrary code to be executed via eval(), which can be leveraged to execute arbitrary code on the target system. Note that there are three underscore characters in the cookie name. This is unrelated to the __cfduid cookie that is legitimately used by Cloudflare.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Bootstrap-sass contains code execution backdoor","id":"CVE-2019-10842","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"code_injection","year":"2019"},"n_packages":2,"n_references":4,"next":{"headline":"DO NOT USE THIS CANDIDATE NUMBER.","id":"CVE-2019-10843"},"packages":[{"ecosystem":"RubyGems","fixed":["3.2.0.4"],"introduced":["3.2.0.3"],"last_affected":[],"package":"bootstrap-sass","purl":null,"source":"GHSA-vqqv-v9m2-48p2"},{"ecosystem":"RubyGems","fixed":["3.2.0.4"],"introduced":["3.2.0.3"],"last_affected":[],"package":"bootstrap-sass","purl":"pkg:gem/bootstrap-sass","source":"GHSA-vqqv-v9m2-48p2"}],"prev":{"headline":"Improperly Controlled Modification of Dynamically-Determined Object Attributes in utilitify","id":"CVE-2019-10808"},"products":["n/a"],"published":"2019-04-04","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"An attacker can execute arbitrary code on systems using the bootstrap-sass library by sending a maliciously crafted cookie value.","url":"https://insights.sbomify.com/CVE-2019-10842/"}