# CVE-2019-10842: Bootstrap-sass contains code execution backdoor

> An attacker can execute arbitrary code on systems using the bootstrap-sass library by sending a maliciously crafted cookie value.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Apr 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-vqqv-v9m2-48p2

## What is CVE-2019-10842?

CVE-2019-10842 is a critical code injection vulnerability in n/a, published on 4 Apr 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Arbitrary code execution (via backdoor code) was discovered in bootstrap-sass 3.2.0.3, when downloaded from rubygems.org. An unauthenticated attacker can craft the ___cfduid cookie value with base64 arbitrary code to be executed via eval(), which can be leveraged to execute arbitrary code on the target system. Note that there are three underscore characters in the cookie name. This is unrelated to the __cfduid cookie that is legitimately used by Cloudflare.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2019-10842?

2 open source packages ship an affected version, including bootstrap-sass. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `bootstrap-sass` | RubyGems | From 3.2.0.3 | 3.2.0.4 |
| `bootstrap-sass` | RubyGems | From 3.2.0.3 | 3.2.0.4 |

Products: Getbootstrap Bootstrap-Sass.

## How do I fix CVE-2019-10842?

Upgrade bootstrap-sass to 3.2.0.4 or later.

## Is CVE-2019-10842 being exploited?

There is no known exploitation of CVE-2019-10842 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-10842 and fix it if it is affected.

What it is: CVE-2019-10842 is a critical code injection vulnerability in n/a, published on 4 Apr 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-10842 in the wild and no public exploit code.

Affected packages and fixed versions:
- bootstrap-sass (RubyGems): affected from 3.2.0.3; fixed in 3.2.0.4
- bootstrap-sass (RubyGems): affected from 3.2.0.3; fixed in 3.2.0.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-10842/ (Markdown: https://insights.sbomify.com/CVE-2019-10842/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-10842
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-10842
- OSV: https://osv.dev/vulnerability/CVE-2019-10842

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-10842/
Summaries are generated and may contain mistakes; the official description above is the record.
