# CVE-2019-10844: Sony Neural Network Libraries reliance on untrusted inputs prior to v1.0.10

> An attacker can manipulate the HOME environment variable to cause the library to read or write files in unintended locations.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Apr 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-4q2w-rw7m-xqw6, PYSEC-2019-107

## What is CVE-2019-10844?

CVE-2019-10844 is a critical path traversal vulnerability in n/a, published on 4 Apr 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

nbla/logger.cpp in libnnabla.a in Sony Neural Network Libraries (aka nnabla) through v1.0.14 relies on the HOME environment variable, which might be untrusted.

## Which versions are affected by CVE-2019-10844?

3 open source packages ship an affected version, including nnabla. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nnabla` | PyPI | All versions | 1.0.10 |
| `nnabla` | PyPI | All versions | 1.0.10 |
| `nnabla` | PyPI | All versions | 1.0.15 |

Products: Sony Neural Network Libraries.

## How do I fix CVE-2019-10844?

Upgrade nnabla to a fixed version for your release line: 1.0.10 or 1.0.15.

## Is CVE-2019-10844 being exploited?

There is no known exploitation of CVE-2019-10844 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-10844 and fix it if it is affected.

What it is: CVE-2019-10844 is a critical path traversal vulnerability in n/a, published on 4 Apr 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-10844 in the wild and no public exploit code.

Affected packages and fixed versions:
- nnabla (PyPI): affected all versions; fixed in 1.0.10
- nnabla (PyPI): affected all versions; fixed in 1.0.10
- nnabla (PyPI): affected all versions; fixed in 1.0.15

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-10844/ (Markdown: https://insights.sbomify.com/CVE-2019-10844/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-10844
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-10844
- OSV: https://osv.dev/vulnerability/CVE-2019-10844

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-10844/
Summaries are generated and may contain mistakes; the official description above is the record.
