# CVE-2019-10867: Pimcore Unserialize Remote Code Execution

> An attacker with class permissions can achieve remote code execution via unsafe deserialization in the bulk-commit endpoint.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Apr 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-7hqr-j26m-gmwp, SNYK-PHP-PIMCOREPIMCORE-173998

## What is CVE-2019-10867?

CVE-2019-10867 is a high-severity unsafe deserialization vulnerability in Pimcore Pimcore, published on 4 Apr 2019. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An issue was discovered in Pimcore before 5.7.1. An attacker with classes permission can send a POST request to /admin/class/bulk-commit, which will make it possible to exploit the unserialize function when passing untrusted values in the data parameter to bundles/AdminBundle/Controller/Admin/DataObject/ClassController.php.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2019-10867?

2 open source packages ship an affected version, including pimcore/pimcore. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pimcore/pimcore` | Packagist | All versions | 5.7.1 |
| `pimcore/pimcore` | Packagist | All versions | 5.7.1 |

Products: Pimcore Pimcore.

## How do I fix CVE-2019-10867?

Upgrade pimcore/pimcore to 5.7.1 or later.

## Is CVE-2019-10867 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2019-10867 exists.

Public exploit code:

- Pimcore Unserialize RCE (metasploit)
- Pimcore < 5.71 - Unserialize Remote Code Execution (Metasploit) (exploitdb)
- Pimcore < 5.71 - Unserialize Remote Code Execution (Metasploit) (exploitdb)

## Other vulnerabilities in Pimcore Pimcore

- [CVE-2022-39365](https://insights.sbomify.com/CVE-2022-39365/): RCE vulnerability in Pimcore/Mail & Dynamic Text Layout (critical 9.8)
- [CVE-2019-18981](https://insights.sbomify.com/CVE-2019-18981/): Pimcore Access Control Issues (critical 9.8)
- [CVE-2019-18985](https://insights.sbomify.com/CVE-2019-18985/): Pimcore 2FA Vulnerable to Brute Forcing (critical 9.8)
- [CVE-2026-23492](https://insights.sbomify.com/CVE-2026-23492/): Pimcore has a Blind SQL Injection in Admin Search Find API due to an incomplete fix for CVE-2023-30848 (high 8.8)
- [CVE-2023-47637](https://insights.sbomify.com/CVE-2023-47637/): SQL Injection in Admin Grid Filter API in Pimcore (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-10867 and fix it if it is affected.

What it is: CVE-2019-10867 is a high-severity unsafe deserialization vulnerability in Pimcore Pimcore, published on 4 Apr 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2019-10867 exists.

Affected packages and fixed versions:
- pimcore/pimcore (Packagist): affected all versions; fixed in 5.7.1
- pimcore/pimcore (Packagist): affected all versions; fixed in 5.7.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-10867/ (Markdown: https://insights.sbomify.com/CVE-2019-10867/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-10867
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-10867
- OSV: https://osv.dev/vulnerability/CVE-2019-10867

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-10867/
Summaries are generated and may contain mistakes; the official description above is the record.
