# CVE-2019-10876: OpenStack Neutron overlapping security group rules prevents compute node network configuration

> An authenticated user can cause a denial of service in OpenStack Neutron by creating conflicting security groups, preventing network configuration on compute nodes.

- **Severity:** Medium 6.5 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Apr 2019
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2019-10876, GHSA-jr9m-v5qh-mh2j, PYSEC-2019-189, UBUNTU-CVE-2019-10876

## What is CVE-2019-10876?

CVE-2019-10876 is a medium-severity denial of service vulnerability in Redhat Openstack, published on 5 Apr 2019. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An issue was discovered in OpenStack Neutron 11.x before 11.0.7, 12.x before 12.0.6, and 13.x before 13.0.3. By creating two security groups with separate/overlapping port ranges, an authenticated user may prevent Neutron from being able to configure networks on any compute nodes where those security groups are present, because of an Open vSwitch (OVS) firewall KeyError. All Neutron deployments utilizing neutron-openvswitch-agent are affected.

## Which versions are affected by CVE-2019-10876?

7 open source packages ship an affected version, including neutron. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `neutron` | PyPI | From 11.0.0 | 11.0.7 |
| `neutron` | PyPI | From 11.0.0 | 11.0.7 |
| `neutron` | PyPI | From 12.0.0 | 12.0.6, 11.0.7, 13.0.3 |
| `neutron` | PyPI | From 12.0.0 | 12.0.6 |
| `neutron` | PyPI | From 12.0.0 | 12.0.6 |
| `neutron` | PyPI | From 13.0.0 | 13.0.3 |
| `neutron` | PyPI | From 13.0.0 | 13.0.3 |

Products: Openstack Neutron, Redhat Openstack.

## How do I fix CVE-2019-10876?

Upgrade neutron to a fixed version for your release line: 11.0.7, 12.0.6 or 13.0.3.

## Is CVE-2019-10876 being exploited?

There is no known exploitation of CVE-2019-10876 in the wild and no public exploit code.

## Other vulnerabilities in Redhat Openstack

- [CVE-2021-38598](https://insights.sbomify.com/CVE-2021-38598/): OpenStack Neutron vulnerable to hardware address impersonation (critical 9.1)
- [CVE-2015-8914](https://insights.sbomify.com/CVE-2015-8914/): OpenStack Neutron allows remote attackers to bypass an intended ICMPv6-spoofing protection mechanism (critical 9.1)
- [CVE-2016-5362](https://insights.sbomify.com/CVE-2016-5362/): OpenStack Neutron allows remote attackers to bypass an intended DHCP-spoofing protection mechanism (high 8.2)
- [CVE-2016-5363](https://insights.sbomify.com/CVE-2016-5363/): OpenStack Neutron Intended MAC-spoofing protection mechanism bypass (high 8.2)
- [CVE-2014-3632](https://insights.sbomify.com/CVE-2014-3632/): Privilege escalation in n/a (high 7.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-10876 and fix it if it is affected.

What it is: CVE-2019-10876 is a medium-severity denial of service vulnerability in Redhat Openstack, published on 5 Apr 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-10876 in the wild and no public exploit code.

Affected packages and fixed versions:
- neutron (PyPI): affected from 11.0.0; fixed in 11.0.7
- neutron (PyPI): affected from 11.0.0; fixed in 11.0.7
- neutron (PyPI): affected from 12.0.0; fixed in 12.0.6, 11.0.7, 13.0.3
- neutron (PyPI): affected from 12.0.0; fixed in 12.0.6
- neutron (PyPI): affected from 12.0.0; fixed in 12.0.6
- neutron (PyPI): affected from 13.0.0; fixed in 13.0.3
- neutron (PyPI): affected from 13.0.0; fixed in 13.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-10876/ (Markdown: https://insights.sbomify.com/CVE-2019-10876/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-10876
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-10876
- OSV: https://osv.dev/vulnerability/CVE-2019-10876

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-10876/
Summaries are generated and may contain mistakes; the official description above is the record.
