CVE-2019-10904 Moderate severity vulnerability that affects roundup

Medium 6.1 Published Updated

Cross-site scripting vulnerability in Roundup issue tracker allows attackers to execute arbitrary scripts via crafted URIs.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2019-10904?

CVE-2019-10904 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 6 Apr 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Roundup 1.6 allows XSS via the URI because frontends/roundup.cgi and roundup/cgi/wsgi_handler.py mishandle 404 errors.

Weakness: CWE-79

Which versions are affected by CVE-2019-10904?

3 open source packages ship an affected version, including roundup. It affects 2 products.

PackageAffectedFixed in
roundup PyPIAll versions2.0.0
roundup PyPIAll versions2.0.0alpha0
roundup PyPIAll versions2.0.0alpha0

Products include Debian Debian Linux, Roundup-Tracker Roundup.

How do I fix CVE-2019-10904?

Upgrade roundup to a fixed version for your release line: 2.0.0 or 2.0.0alpha0.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2019-10904 being exploited?

There is no known exploitation of CVE-2019-10904 in the wild and no public exploit code.

All Debian Debian Linux vulnerabilities

Sources

Also known as DLA-1750-1, GHSA-926q-wxr6-3crq, PYSEC-2019-201, UBUNTU-CVE-2019-10904.

Is CVE-2019-10904 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free