{"answers":{"affected":"2 open source packages ship an affected version, including erusev/parsedown. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-10905 in the wild and no public exploit code.","fix":"Upgrade erusev/parsedown to 1.7.2 or later.","what":"CVE-2019-10905 is a high-severity cross-site scripting vulnerability in n/a, published on 6 Apr 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-10905 and fix it if it is affected.\n\nWhat it is: CVE-2019-10905 is a high-severity cross-site scripting vulnerability in n/a, published on 6 Apr 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-10905 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- erusev/parsedown (Packagist): affected all versions; fixed in 1.7.2\n- erusev/parsedown (Packagist): affected all versions; fixed in 1.7.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-10905/ (Markdown: https://insights.sbomify.com/CVE-2019-10905/index.md)","id":"CVE-2019-10905","markdown":"https://insights.sbomify.com/CVE-2019-10905/index.md","name":"CVE-2019-10905","record":{"aliases":["GHSA-62m3-fc7f-jpp8"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"PHP Markdown parser","requires_auth":"none","summary":"Attackers can execute arbitrary JavaScript via crafted Markdown when safe mode is enabled and HTML is disabled, affecting applications using Parsedown.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"parsedown","vendor":"parsedown"}],"cvss":{"score":8.1,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Parsedown before 1.7.2, when safe mode is used and HTML markup is disabled, might allow attackers to execute arbitrary JavaScript code if a script (already running on the affected page) executes the contents of any element with a specific class. This occurs because spaces are permitted in code block infostrings, which interferes with the intended behavior of a single class name beginning with the language- substring.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Parsedown Class-Name Injection","id":"CVE-2019-10905","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2019"},"n_packages":2,"n_references":2,"next":{"headline":"Jinja2 sandbox escape via string formatting","id":"CVE-2019-10906"},"packages":[{"ecosystem":"Packagist","fixed":["1.7.2"],"introduced":["0"],"last_affected":[],"package":"erusev/parsedown","purl":null,"source":"GHSA-62m3-fc7f-jpp8"},{"ecosystem":"Packagist","fixed":["1.7.2"],"introduced":["0"],"last_affected":[],"package":"erusev/parsedown","purl":"pkg:composer/erusev/parsedown","source":"GHSA-62m3-fc7f-jpp8"}],"prev":{"headline":"Moderate severity vulnerability that affects roundup","id":"CVE-2019-10904"},"products":["n/a"],"published":"2019-04-06","related":[{"cvss_score":6.1,"headline":"Cross-site Scripting in Parsedown","id":"CVE-2018-1000162","kev_date_added":null,"published":"2018-04-18"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Attackers can execute arbitrary JavaScript via crafted Markdown when safe mode is enabled and HTML is disabled, affecting applications using Parsedown.","url":"https://insights.sbomify.com/CVE-2019-10905/"}