CVE-2019-10909 Symfony Cross-site Scripting (XSS) vulnerability
Cross-site scripting vulnerability in Symfony allows attackers to inject malicious scripts via unescaped validation messages containing user input.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2019-10909?
CVE-2019-10909 is a medium-severity cross-site scripting vulnerability in Drupal Drupal, published on 16 May 2019. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
In Symfony before 2.7.51, 2.8.x before 2.8.50, 3.x before 3.4.26, 4.x before 4.1.12, and 4.2.x before 4.2.7, validation messages are not escaped, which can lead to XSS when user input is included. This is related to symfony/framework-bundle.
Weakness: CWE-79
Which versions are affected by CVE-2019-10909?
28 open source packages ship an affected version, including drupal/core, drupal/drupal and symfony/framework-bundle. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
drupal/core Packagist | From 8.0.0 | 8.5.15 |
drupal/core Packagist | From 8.0.0 | 8.5.15 |
drupal/core Packagist | From 8.6.0 | 8.6.15 |
drupal/core Packagist | From 8.6.0 | 8.6.15 |
drupal/drupal Packagist | From 8.0.0 | 8.5.15 |
drupal/drupal Packagist | From 8.0.0 | 8.5.15 |
22 more packages
drupal/drupal Packagist | From 8.6.0 | 8.6.15 |
drupal/drupal Packagist | From 8.6.0 | 8.6.15 |
symfony/framework-bundle Packagist | From 2.7.0 | 2.7.51 |
symfony/framework-bundle Packagist | From 2.7.0 | 2.7.51 |
symfony/framework-bundle Packagist | From 2.8.0 | 2.8.50 |
symfony/framework-bundle Packagist | From 2.8.0 | 2.8.50 |
symfony/framework-bundle Packagist | From 3.0.0 | 3.4.26 |
symfony/framework-bundle Packagist | From 3.0.0 | 3.4.26 |
symfony/framework-bundle Packagist | From 4.0.0 | 4.1.12 |
symfony/framework-bundle Packagist | From 4.0.0 | 4.1.12 |
symfony/framework-bundle Packagist | From 4.2.0 | 4.2.7 |
symfony/framework-bundle Packagist | From 4.2.0 | 4.2.7 |
symfony/symfony Packagist | From 2.7.0 | 2.7.51 |
symfony/symfony Packagist | From 2.7.0 | 2.7.51 |
symfony/symfony Packagist | From 2.8.0 | 2.8.50 |
symfony/symfony Packagist | From 2.8.0 | 2.8.50 |
symfony/symfony Packagist | From 3.0.0 | 3.4.26 |
symfony/symfony Packagist | From 3.0.0 | 3.4.26 |
symfony/symfony Packagist | From 4.0.0 | 4.1.12 |
symfony/symfony Packagist | From 4.0.0 | 4.1.12 |
symfony/symfony Packagist | From 4.2.0 | 4.2.7 |
symfony/symfony Packagist | From 4.2.0 | 4.2.7 |
Products include Drupal Drupal, Sensiolabs Symfony.
How do I fix CVE-2019-10909?
Upgrade drupal/core to a fixed version for your release line: 8.5.15 or 8.6.15.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2019-10909 being exploited?
There is no known exploitation of CVE-2019-10909 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Other vulnerabilities in Drupal Drupal
Sources
Also known as DEBIAN-CVE-2019-10909, GHSA-g996-q5r8-w7g2, UBUNTU-CVE-2019-10909.