# CVE-2019-10909: Symfony Cross-site Scripting (XSS) vulnerability

> Cross-site scripting vulnerability in Symfony allows attackers to inject malicious scripts via unescaped validation messages containing user input.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 16 May 2019
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2019-10909, GHSA-g996-q5r8-w7g2, UBUNTU-CVE-2019-10909

## What is CVE-2019-10909?

CVE-2019-10909 is a medium-severity cross-site scripting vulnerability in Drupal Drupal, published on 16 May 2019. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

In Symfony before 2.7.51, 2.8.x before 2.8.50, 3.x before 3.4.26, 4.x before 4.1.12, and 4.2.x before 4.2.7, validation messages are not escaped, which can lead to XSS when user input is included. This is related to symfony/framework-bundle.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2019-10909?

28 open source packages ship an affected version, including drupal/core, drupal/drupal and symfony/framework-bundle. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `drupal/core` | Packagist | From 8.0.0 | 8.5.15 |
| `drupal/core` | Packagist | From 8.0.0 | 8.5.15 |
| `drupal/core` | Packagist | From 8.6.0 | 8.6.15 |
| `drupal/core` | Packagist | From 8.6.0 | 8.6.15 |
| `drupal/drupal` | Packagist | From 8.0.0 | 8.5.15 |
| `drupal/drupal` | Packagist | From 8.0.0 | 8.5.15 |
| `drupal/drupal` | Packagist | From 8.6.0 | 8.6.15 |
| `drupal/drupal` | Packagist | From 8.6.0 | 8.6.15 |
| `symfony/framework-bundle` | Packagist | From 2.7.0 | 2.7.51 |
| `symfony/framework-bundle` | Packagist | From 2.7.0 | 2.7.51 |
| `symfony/framework-bundle` | Packagist | From 2.8.0 | 2.8.50 |
| `symfony/framework-bundle` | Packagist | From 2.8.0 | 2.8.50 |
| `symfony/framework-bundle` | Packagist | From 3.0.0 | 3.4.26 |
| `symfony/framework-bundle` | Packagist | From 3.0.0 | 3.4.26 |
| `symfony/framework-bundle` | Packagist | From 4.0.0 | 4.1.12 |
| `symfony/framework-bundle` | Packagist | From 4.0.0 | 4.1.12 |
| `symfony/framework-bundle` | Packagist | From 4.2.0 | 4.2.7 |
| `symfony/framework-bundle` | Packagist | From 4.2.0 | 4.2.7 |
| `symfony/symfony` | Packagist | From 2.7.0 | 2.7.51 |
| `symfony/symfony` | Packagist | From 2.7.0 | 2.7.51 |
| `symfony/symfony` | Packagist | From 2.8.0 | 2.8.50 |
| `symfony/symfony` | Packagist | From 2.8.0 | 2.8.50 |
| `symfony/symfony` | Packagist | From 3.0.0 | 3.4.26 |
| `symfony/symfony` | Packagist | From 3.0.0 | 3.4.26 |
| `symfony/symfony` | Packagist | From 4.0.0 | 4.1.12 |
| `symfony/symfony` | Packagist | From 4.0.0 | 4.1.12 |
| `symfony/symfony` | Packagist | From 4.2.0 | 4.2.7 |
| `symfony/symfony` | Packagist | From 4.2.0 | 4.2.7 |

Products: Drupal Drupal, Sensiolabs Symfony.

## How do I fix CVE-2019-10909?

Upgrade drupal/core to a fixed version for your release line: 8.5.15 or 8.6.15.

## Is CVE-2019-10909 being exploited?

There is no known exploitation of CVE-2019-10909 in the wild and no public exploit code.

Public exploit code:

-  CVE-2021-21424 - CRLF Injection - CVE-2021-41268 - Host Header Injection - CVE-2022-24894 - WebProfiler abierto - CVE-2019-10909 - Directory Traversal (github_poc): https://github.com/moften/Symfony-CVE-Scanner-PoC-

## Other vulnerabilities in Drupal Drupal

- [CVE-2026-9082](https://insights.sbomify.com/CVE-2026-9082/): Drupal Core SQL Injection (critical 9.8, exploited in the wild)
- [CVE-2020-13671](https://insights.sbomify.com/CVE-2020-13671/): Drupal core Un-restricted Upload of File (high 8.8, exploited in the wild)
- [CVE-2019-6340](https://insights.sbomify.com/CVE-2019-6340/): Drupal Core Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2009-3352](https://insights.sbomify.com/CVE-2009-3352/): Other in n/a (critical 10.0)
- [CVE-2024-55636](https://insights.sbomify.com/CVE-2024-55636/): Drupal core - Less critical - Gadget chain - SA-CORE-2024-006 (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-10909 and fix it if it is affected.

What it is: CVE-2019-10909 is a medium-severity cross-site scripting vulnerability in Drupal Drupal, published on 16 May 2019. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-10909 in the wild and no public exploit code.

Affected packages and fixed versions:
- drupal/core (Packagist): affected from 8.0.0; fixed in 8.5.15
- drupal/core (Packagist): affected from 8.0.0; fixed in 8.5.15
- drupal/core (Packagist): affected from 8.6.0; fixed in 8.6.15
- drupal/core (Packagist): affected from 8.6.0; fixed in 8.6.15
- drupal/drupal (Packagist): affected from 8.0.0; fixed in 8.5.15
- drupal/drupal (Packagist): affected from 8.0.0; fixed in 8.5.15
- drupal/drupal (Packagist): affected from 8.6.0; fixed in 8.6.15
- drupal/drupal (Packagist): affected from 8.6.0; fixed in 8.6.15
- symfony/framework-bundle (Packagist): affected from 2.7.0; fixed in 2.7.51
- symfony/framework-bundle (Packagist): affected from 2.7.0; fixed in 2.7.51
- symfony/framework-bundle (Packagist): affected from 2.8.0; fixed in 2.8.50
- symfony/framework-bundle (Packagist): affected from 2.8.0; fixed in 2.8.50

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-10909/ (Markdown: https://insights.sbomify.com/CVE-2019-10909/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-10909
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-10909
- OSV: https://osv.dev/vulnerability/CVE-2019-10909

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-10909/
Summaries are generated and may contain mistakes; the official description above is the record.
