CVE-2019-10910 Symfony Service IDs Allow Injection
Attackers can achieve remote code execution and SQL injection in Symfony applications if service IDs accept user input.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2019-10910?
CVE-2019-10910 is a critical SQL injection vulnerability in Drupal Drupal, published on 16 May 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
In Symfony before 2.7.51, 2.8.x before 2.8.50, 3.x before 3.4.26, 4.x before 4.1.12, and 4.2.x before 4.2.7, when service ids allow user input, this could allow for SQL Injection and remote code execution. This is related to symfony/dependency-injection.
Weakness: CWE-89
Which versions are affected by CVE-2019-10910?
30 open source packages ship an affected version, including symfony/dependency-injection, symfony/proxy-manager-bridge and symfony/symfony. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
symfony/dependency-injection Packagist | From 2.7.0 | 2.7.51 |
symfony/dependency-injection Packagist | From 2.7.0 | 2.7.51 |
symfony/dependency-injection Packagist | From 2.8.0 | 2.8.50 |
symfony/dependency-injection Packagist | From 2.8.0 | 2.8.50 |
symfony/dependency-injection Packagist | From 3.0.0 | 3.4.26 |
symfony/dependency-injection Packagist | From 3.0.0 | 3.4.26 |
24 more packages
symfony/dependency-injection Packagist | From 4.0.0 | 4.1.12 |
symfony/dependency-injection Packagist | From 4.0.0 | 4.1.12 |
symfony/dependency-injection Packagist | From 4.2.0 | 4.2.7 |
symfony/dependency-injection Packagist | From 4.2.0 | 4.2.7 |
symfony/proxy-manager-bridge Packagist | From 2.7.0 | 2.7.51 |
symfony/proxy-manager-bridge Packagist | From 2.7.0 | 2.7.51 |
symfony/proxy-manager-bridge Packagist | From 2.8.0 | 2.8.50 |
symfony/proxy-manager-bridge Packagist | From 2.8.0 | 2.8.50 |
symfony/proxy-manager-bridge Packagist | From 3.0.0 | 3.4.26 |
symfony/proxy-manager-bridge Packagist | From 3.0.0 | 3.4.26 |
symfony/proxy-manager-bridge Packagist | From 4.0.0 | 4.1.12 |
symfony/proxy-manager-bridge Packagist | From 4.0.0 | 4.1.12 |
symfony/proxy-manager-bridge Packagist | From 4.2.0 | 4.2.7 |
symfony/proxy-manager-bridge Packagist | From 4.2.0 | 4.2.7 |
symfony/symfony Packagist | From 2.7.0 | 2.7.51 |
symfony/symfony Packagist | From 2.7.0 | 2.7.51 |
symfony/symfony Packagist | From 2.8.0 | 2.8.50 |
symfony/symfony Packagist | From 2.8.0 | 2.8.50 |
symfony/symfony Packagist | From 3.0.0 | 3.4.26 |
symfony/symfony Packagist | From 3.0.0 | 3.4.26 |
symfony/symfony Packagist | From 4.0.0 | 4.1.12 |
symfony/symfony Packagist | From 4.0.0 | 4.1.12 |
symfony/symfony Packagist | From 4.2.0 | 4.2.7 |
symfony/symfony Packagist | From 4.2.0 | 4.2.7 |
Products include Drupal Drupal, Sensiolabs Symfony.
How do I fix CVE-2019-10910?
Upgrade symfony/dependency-injection to a fixed version for your release line: 2.7.51, 2.8.50, 3.4.26 or 4.1.12.
Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.
Is CVE-2019-10910 being exploited?
There is no known exploitation of CVE-2019-10910 in the wild and no public exploit code.
Other vulnerabilities in Drupal Drupal
Sources
Also known as DEBIAN-CVE-2019-10910, GHSA-pgwj-prpq-jpc2, UBUNTU-CVE-2019-10910.