CVE-2019-10911 Improper authentication in Symfony
An attacker can authenticate as a privileged user on sites using Symfony's remember me feature with user registration enabled.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2019-10911?
CVE-2019-10911 is a high-severity authentication bypass vulnerability in Drupal Drupal, published on 16 May 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
In Symfony before 2.7.51, 2.8.x before 2.8.50, 3.x before 3.4.26, 4.x before 4.1.12, and 4.2.x before 4.2.7, a vulnerability would allow an attacker to authenticate as a privileged user on sites with user registration and remember me login functionality enabled. This is related to symfony/security.
Weakness: CWE-287
Which versions are affected by CVE-2019-10911?
30 open source packages ship an affected version, including symfony/security, symfony/security-http and symfony/symfony. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
symfony/security Packagist | From 2.7.0 | 2.7.51 |
symfony/security Packagist | From 2.7.0 | 2.7.51 |
symfony/security Packagist | From 2.8.0 | 2.8.50 |
symfony/security Packagist | From 2.8.0 | 2.8.50 |
symfony/security Packagist | From 3.0.0 | 3.4.26 |
symfony/security Packagist | From 3.0.0 | 3.4.26 |
24 more packages
symfony/security Packagist | From 4.0.0 | 4.1.12 |
symfony/security Packagist | From 4.0.0 | 4.1.12 |
symfony/security Packagist | From 4.2.0 | 4.2.7 |
symfony/security Packagist | From 4.2.0 | 4.2.7 |
symfony/security-http Packagist | From 2.7.0 | 2.7.51 |
symfony/security-http Packagist | From 2.7.0 | 2.7.51 |
symfony/security-http Packagist | From 2.8.0 | 2.8.50 |
symfony/security-http Packagist | From 2.8.0 | 2.8.50 |
symfony/security-http Packagist | From 3.0.0 | 3.4.26 |
symfony/security-http Packagist | From 3.0.0 | 3.4.26 |
symfony/security-http Packagist | From 4.0.0 | 4.1.12 |
symfony/security-http Packagist | From 4.0.0 | 4.1.12 |
symfony/security-http Packagist | From 4.2.0 | 4.2.7 |
symfony/security-http Packagist | From 4.2.0 | 4.2.7 |
symfony/symfony Packagist | From 2.7.0 | 2.7.51 |
symfony/symfony Packagist | From 2.7.0 | 2.7.51 |
symfony/symfony Packagist | From 2.8.0 | 2.8.50 |
symfony/symfony Packagist | From 2.8.0 | 2.8.50 |
symfony/symfony Packagist | From 3.0.0 | 3.4.26 |
symfony/symfony Packagist | From 3.0.0 | 3.4.26 |
symfony/symfony Packagist | From 4.0.0 | 4.1.12 |
symfony/symfony Packagist | From 4.0.0 | 4.1.12 |
symfony/symfony Packagist | From 4.2.0 | 4.2.7 |
symfony/symfony Packagist | From 4.2.0 | 4.2.7 |
Products include Drupal Drupal, Sensiolabs Symfony.
How do I fix CVE-2019-10911?
Upgrade symfony/security to a fixed version for your release line: 2.7.51, 2.8.50, 3.4.26 or 4.1.12.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2019-10911 being exploited?
There is no known exploitation of CVE-2019-10911 in the wild and no public exploit code.
Other vulnerabilities in Drupal Drupal
Sources
Also known as DEBIAN-CVE-2019-10911, GHSA-cchx-mfrc-fwqr, UBUNTU-CVE-2019-10911.