# CVE-2019-10911: Improper authentication in Symfony

> An attacker can authenticate as a privileged user on sites using Symfony's remember me feature with user registration enabled.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 May 2019
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2019-10911, GHSA-cchx-mfrc-fwqr, UBUNTU-CVE-2019-10911

## What is CVE-2019-10911?

CVE-2019-10911 is a high-severity authentication bypass vulnerability in Drupal Drupal, published on 16 May 2019. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

In Symfony before 2.7.51, 2.8.x before 2.8.50, 3.x before 3.4.26, 4.x before 4.1.12, and 4.2.x before 4.2.7, a vulnerability would allow an attacker to authenticate as a privileged user on sites with user registration and remember me login functionality enabled. This is related to symfony/security.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2019-10911?

30 open source packages ship an affected version, including symfony/security, symfony/security-http and symfony/symfony. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `symfony/security` | Packagist | From 2.7.0 | 2.7.51 |
| `symfony/security` | Packagist | From 2.7.0 | 2.7.51 |
| `symfony/security` | Packagist | From 2.8.0 | 2.8.50 |
| `symfony/security` | Packagist | From 2.8.0 | 2.8.50 |
| `symfony/security` | Packagist | From 3.0.0 | 3.4.26 |
| `symfony/security` | Packagist | From 3.0.0 | 3.4.26 |
| `symfony/security` | Packagist | From 4.0.0 | 4.1.12 |
| `symfony/security` | Packagist | From 4.0.0 | 4.1.12 |
| `symfony/security` | Packagist | From 4.2.0 | 4.2.7 |
| `symfony/security` | Packagist | From 4.2.0 | 4.2.7 |
| `symfony/security-http` | Packagist | From 2.7.0 | 2.7.51 |
| `symfony/security-http` | Packagist | From 2.7.0 | 2.7.51 |
| `symfony/security-http` | Packagist | From 2.8.0 | 2.8.50 |
| `symfony/security-http` | Packagist | From 2.8.0 | 2.8.50 |
| `symfony/security-http` | Packagist | From 3.0.0 | 3.4.26 |
| `symfony/security-http` | Packagist | From 3.0.0 | 3.4.26 |
| `symfony/security-http` | Packagist | From 4.0.0 | 4.1.12 |
| `symfony/security-http` | Packagist | From 4.0.0 | 4.1.12 |
| `symfony/security-http` | Packagist | From 4.2.0 | 4.2.7 |
| `symfony/security-http` | Packagist | From 4.2.0 | 4.2.7 |
| `symfony/symfony` | Packagist | From 2.7.0 | 2.7.51 |
| `symfony/symfony` | Packagist | From 2.7.0 | 2.7.51 |
| `symfony/symfony` | Packagist | From 2.8.0 | 2.8.50 |
| `symfony/symfony` | Packagist | From 2.8.0 | 2.8.50 |
| `symfony/symfony` | Packagist | From 3.0.0 | 3.4.26 |
| `symfony/symfony` | Packagist | From 3.0.0 | 3.4.26 |
| `symfony/symfony` | Packagist | From 4.0.0 | 4.1.12 |
| `symfony/symfony` | Packagist | From 4.0.0 | 4.1.12 |
| `symfony/symfony` | Packagist | From 4.2.0 | 4.2.7 |
| `symfony/symfony` | Packagist | From 4.2.0 | 4.2.7 |

Products: Drupal Drupal, Sensiolabs Symfony.

## How do I fix CVE-2019-10911?

Upgrade symfony/security to a fixed version for your release line: 2.7.51, 2.8.50, 3.4.26 or 4.1.12.

## Is CVE-2019-10911 being exploited?

There is no known exploitation of CVE-2019-10911 in the wild and no public exploit code.

## Other vulnerabilities in Drupal Drupal

- [CVE-2026-9082](https://insights.sbomify.com/CVE-2026-9082/): Drupal Core SQL Injection (critical 9.8, exploited in the wild)
- [CVE-2020-13671](https://insights.sbomify.com/CVE-2020-13671/): Drupal core Un-restricted Upload of File (high 8.8, exploited in the wild)
- [CVE-2019-6340](https://insights.sbomify.com/CVE-2019-6340/): Drupal Core Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2009-3352](https://insights.sbomify.com/CVE-2009-3352/): Other in n/a (critical 10.0)
- [CVE-2024-55636](https://insights.sbomify.com/CVE-2024-55636/): Drupal core - Less critical - Gadget chain - SA-CORE-2024-006 (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-10911 and fix it if it is affected.

What it is: CVE-2019-10911 is a high-severity authentication bypass vulnerability in Drupal Drupal, published on 16 May 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-10911 in the wild and no public exploit code.

Affected packages and fixed versions:
- symfony/security (Packagist): affected from 2.7.0; fixed in 2.7.51
- symfony/security (Packagist): affected from 2.7.0; fixed in 2.7.51
- symfony/security (Packagist): affected from 2.8.0; fixed in 2.8.50
- symfony/security (Packagist): affected from 2.8.0; fixed in 2.8.50
- symfony/security (Packagist): affected from 3.0.0; fixed in 3.4.26
- symfony/security (Packagist): affected from 3.0.0; fixed in 3.4.26
- symfony/security (Packagist): affected from 4.0.0; fixed in 4.1.12
- symfony/security (Packagist): affected from 4.0.0; fixed in 4.1.12
- symfony/security (Packagist): affected from 4.2.0; fixed in 4.2.7
- symfony/security (Packagist): affected from 4.2.0; fixed in 4.2.7
- symfony/security-http (Packagist): affected from 2.7.0; fixed in 2.7.51
- symfony/security-http (Packagist): affected from 2.7.0; fixed in 2.7.51

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-10911/ (Markdown: https://insights.sbomify.com/CVE-2019-10911/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-10911
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-10911
- OSV: https://osv.dev/vulnerability/CVE-2019-10911

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-10911/
Summaries are generated and may contain mistakes; the official description above is the record.
