# CVE-2019-10912: Deserialization of untrusted data in Symfony

> Attackers can delete files accessible to the application user by exploiting unsafe deserialization in Symfony's caching mechanism.

- **Severity:** High 7.1 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 May 2019
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2019-10912, GHSA-w2fr-65vp-mxw3, UBUNTU-CVE-2019-10912

## What is CVE-2019-10912?

CVE-2019-10912 is a high-severity unsafe deserialization vulnerability in Sensiolabs Symfony, published on 16 May 2019. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

In Symfony before 2.8.50, 3.x before 3.4.26, 4.x before 4.1.12, and 4.2.x before 4.2.7, it is possible to cache objects that may contain bad user input. On serialization or unserialization, this could result in the deletion of files that the current user has access to. This is related to symfony/cache and symfony/phpunit-bridge.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2019-10912?

26 open source packages ship an affected version, including symfony/phpunit-bridge, symfony/cache and symfony/symfony. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `symfony/phpunit-bridge` | Packagist | From 2.8.0 | 2.8.50 |
| `symfony/phpunit-bridge` | Packagist | From 2.8.0 | 2.8.50 |
| `symfony/phpunit-bridge` | Packagist | From 3.0.0 | 3.4.26 |
| `symfony/phpunit-bridge` | Packagist | From 3.0.0 | 3.4.26 |
| `symfony/phpunit-bridge` | Packagist | From 4.0.0 | 4.1.12 |
| `symfony/phpunit-bridge` | Packagist | From 4.0.0 | 4.1.12 |
| `symfony/phpunit-bridge` | Packagist | From 4.2.0 | 4.2.7 |
| `symfony/phpunit-bridge` | Packagist | From 4.2.0 | 4.2.7 |
| `symfony/cache` | Packagist | From 3.1.0 | 3.4.26 |
| `symfony/cache` | Packagist | From 3.1.0 | 3.4.26 |
| `symfony/cache` | Packagist | From 4.0.0 | 4.1.12 |
| `symfony/cache` | Packagist | From 4.0.0 | 4.1.12 |
| `symfony/cache` | Packagist | From 4.2.0 | 4.2.7 |
| `symfony/cache` | Packagist | From 4.2.0 | 4.2.7 |
| `symfony/symfony` | Packagist | From 2.8.0 | 2.8.50 |
| `symfony/symfony` | Packagist | From 2.8.0 | 2.8.50 |
| `symfony/symfony` | Packagist | From 3.0.0 | 3.4.26 |
| `symfony/symfony` | Packagist | From 3.0.0 | 3.4.26 |
| `symfony/symfony` | Packagist | From 4.0.0 | 4.1.12 |
| `symfony/symfony` | Packagist | From 4.0.0 | 4.1.12 |
| `symfony/symfony` | Packagist | From 4.2.0 | 4.2.7 |
| `symfony/symfony` | Packagist | From 4.2.0 | 4.2.7 |
| `typo3/cms` | Packagist | From 9.0.0 | 9.5.8 |
| `typo3/cms` | Packagist | From 9.0.0 | 9.5.8 |
| `typo3/cms-core` | Packagist | From 9.0.0 | 9.5.8 |
| `typo3/cms-core` | Packagist | From 9.0.0 | 9.5.8 |

Products: Sensiolabs Symfony.

## How do I fix CVE-2019-10912?

Upgrade symfony/phpunit-bridge to a fixed version for your release line: 2.8.50, 3.4.26, 4.1.12 or 4.2.7.

## Is CVE-2019-10912 being exploited?

There is no known exploitation of CVE-2019-10912 in the wild and no public exploit code.

## Other vulnerabilities in Sensiolabs Symfony

- [CVE-2019-11325](https://insights.sbomify.com/CVE-2019-11325/): Improper Input Validation in Symfony (critical 9.8)
- [CVE-2017-11365](https://insights.sbomify.com/CVE-2017-11365/): Symfony Incorrect Access Control (critical 9.8)
- [CVE-2019-10913](https://insights.sbomify.com/CVE-2019-10913/): Invalid HTTP method overrides allow possible XSS or other attacks in Symfony (critical 9.8)
- [CVE-2018-11407](https://insights.sbomify.com/CVE-2018-11407/): Symfony Authentication Bypass (critical 9.8)
- [CVE-2016-2403](https://insights.sbomify.com/CVE-2016-2403/): Symfony Authentication Bypass (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-10912 and fix it if it is affected.

What it is: CVE-2019-10912 is a high-severity unsafe deserialization vulnerability in Sensiolabs Symfony, published on 16 May 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-10912 in the wild and no public exploit code.

Affected packages and fixed versions:
- symfony/phpunit-bridge (Packagist): affected from 2.8.0; fixed in 2.8.50
- symfony/phpunit-bridge (Packagist): affected from 2.8.0; fixed in 2.8.50
- symfony/phpunit-bridge (Packagist): affected from 3.0.0; fixed in 3.4.26
- symfony/phpunit-bridge (Packagist): affected from 3.0.0; fixed in 3.4.26
- symfony/phpunit-bridge (Packagist): affected from 4.0.0; fixed in 4.1.12
- symfony/phpunit-bridge (Packagist): affected from 4.0.0; fixed in 4.1.12
- symfony/phpunit-bridge (Packagist): affected from 4.2.0; fixed in 4.2.7
- symfony/phpunit-bridge (Packagist): affected from 4.2.0; fixed in 4.2.7
- symfony/cache (Packagist): affected from 3.1.0; fixed in 3.4.26
- symfony/cache (Packagist): affected from 3.1.0; fixed in 3.4.26
- symfony/cache (Packagist): affected from 4.0.0; fixed in 4.1.12
- symfony/cache (Packagist): affected from 4.0.0; fixed in 4.1.12

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-10912/ (Markdown: https://insights.sbomify.com/CVE-2019-10912/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-10912
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-10912
- OSV: https://osv.dev/vulnerability/CVE-2019-10912

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-10912/
Summaries are generated and may contain mistakes; the official description above is the record.
