CVE-2019-10913 Invalid HTTP method overrides allow possible XSS or other attacks in Symfony
Attackers can exploit unvalidated HTTP method overrides in Symfony to perform SQL injection or XSS attacks.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2019-10913?
CVE-2019-10913 is a critical SQL injection vulnerability in Sensiolabs Symfony, published on 16 May 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
In Symfony before 2.7.51, 2.8.x before 2.8.50, 3.x before 3.4.26, 4.x before 4.1.12, and 4.2.x before 4.2.7, HTTP Methods provided as verbs or using the override header may be treated as trusted input, but they are not validated, possibly causing SQL injection or XSS. This is related to symfony/http-foundation.
Which versions are affected by CVE-2019-10913?
20 open source packages ship an affected version, including symfony/http-foundation and symfony/symfony. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
symfony/http-foundation Packagist | From 2.7.0 | 2.7.51 |
symfony/http-foundation Packagist | From 2.7.0 | 2.7.51 |
symfony/http-foundation Packagist | From 2.8.0 | 2.8.50 |
symfony/http-foundation Packagist | From 2.8.0 | 2.8.50 |
symfony/http-foundation Packagist | From 3.0.0 | 3.4.26 |
symfony/http-foundation Packagist | From 3.0.0 | 3.4.26 |
14 more packages
symfony/http-foundation Packagist | From 4.0.0 | 4.1.12 |
symfony/http-foundation Packagist | From 4.0.0 | 4.1.12 |
symfony/http-foundation Packagist | From 4.2.0 | 4.2.7 |
symfony/http-foundation Packagist | From 4.2.0 | 4.2.7 |
symfony/symfony Packagist | From 2.7.0 | 2.7.51 |
symfony/symfony Packagist | From 2.7.0 | 2.7.51 |
symfony/symfony Packagist | From 2.8.0 | 2.8.50 |
symfony/symfony Packagist | From 2.8.0 | 2.8.50 |
symfony/symfony Packagist | From 3.0.0 | 3.4.26 |
symfony/symfony Packagist | From 3.0.0 | 3.4.26 |
symfony/symfony Packagist | From 4.0.0 | 4.1.12 |
symfony/symfony Packagist | From 4.0.0 | 4.1.12 |
symfony/symfony Packagist | From 4.2.0 | 4.2.7 |
symfony/symfony Packagist | From 4.2.0 | 4.2.7 |
Products include Sensiolabs Symfony.
How do I fix CVE-2019-10913?
Upgrade symfony/http-foundation to a fixed version for your release line: 2.7.51, 2.8.50, 3.4.26 or 4.1.12.
Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.
Is CVE-2019-10913 being exploited?
There is no known exploitation of CVE-2019-10913 in the wild and no public exploit code.
Other vulnerabilities in Sensiolabs Symfony
Sources
Also known as DEBIAN-CVE-2019-10913, GHSA-x92h-wmg2-6hp7, UBUNTU-CVE-2019-10913.