# CVE-2019-10970: Auth bypass in Rockwell Automation PanelView 5510

> Remote attackers can bypass authentication to gain root access on Rockwell PanelView 5510 devices, requiring firmware updates to mitigate.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 11 Jul 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-3pr6-q8r5-4wq6

## What is CVE-2019-10970?

CVE-2019-10970 is a critical authentication bypass vulnerability in Rockwell Automation PanelView 5510, published on 11 Jul 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Rockwell Automation PanelView 5510 (all versions manufactured before March 13, 2019 that have never been updated to v4.003, v5.002, or later), a remote, unauthenticated threat actor with access to an affected PanelView 5510 Graphic Display, upon successful exploit, may boot-up the terminal and gain root-level access to the device’s file system.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2019-10970?

It affects 1 product.


Products: Rockwellautomation Panelview 5510 Firmware.

## How do I fix CVE-2019-10970?

No fix has been published for CVE-2019-10970 yet. Limit exposure of the affected software until one is available.

## Is CVE-2019-10970 being exploited?

There is no known exploitation of CVE-2019-10970 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-10970 and fix it if it is affected.

What it is: CVE-2019-10970 is a critical authentication bypass vulnerability in Rockwell Automation PanelView 5510, published on 11 Jul 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-10970 in the wild and no public exploit code.

Affected product: Rockwell Automation PanelView 5510. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-10970/ (Markdown: https://insights.sbomify.com/CVE-2019-10970/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-10970
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-10970
- OSV: https://osv.dev/vulnerability/CVE-2019-10970

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-10970/
Summaries are generated and may contain mistakes; the official description above is the record.
