{"answers":{"affected":"4 open source packages ship an affected version, including @materializecss/materialize and materialize-css. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-11004 in the wild and no public exploit code.","fix":"Upgrade @materializecss/materialize to 1.1.0-alpha or later.","what":"CVE-2019-11004 is a medium-severity cross-site scripting vulnerability in n/a, published on 8 Apr 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2019-11004 and fix it if it is affected.\n\nWhat it is: CVE-2019-11004 is a medium-severity cross-site scripting vulnerability in n/a, published on 8 Apr 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2019-11004 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @materializecss/materialize (npm): affected all versions; fixed in 1.1.0-alpha\n- @materializecss/materialize (npm): affected all versions; fixed in 1.1.0-alpha\n- materialize-css (npm): affected all versions up to 1.0.0; no fix listed\n- materialize-css (npm): affected all versions up to 1.0.0; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-11004/ (Markdown: https://insights.sbomify.com/CVE-2019-11004/index.md)","id":"CVE-2019-11004","markdown":"https://insights.sbomify.com/CVE-2019-11004/index.md","name":"CVE-2019-11004","record":{"aliases":["GHSA-rg3q-jxmp-pvjj"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Materialize CSS framework","requires_auth":"none","summary":"Cross-site scripting vulnerability in Materialize allows attackers to inject malicious scripts via the Toast feature.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"materialize","vendor":"materializecss"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"In Materialize through 1.0.0, XSS is possible via the Toast feature.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Materialize-css vulnerable to Improper Neutralization of Input During Web Page Generation","id":"CVE-2019-11004","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2019"},"n_packages":4,"n_references":1,"next":{"headline":"Memory corruption in n/a","id":"CVE-2019-11005"},"packages":[{"ecosystem":"npm","fixed":["1.1.0-alpha"],"introduced":["0"],"last_affected":[],"package":"@materializecss/materialize","purl":null,"source":"GHSA-rg3q-jxmp-pvjj"},{"ecosystem":"npm","fixed":["1.1.0-alpha"],"introduced":["0"],"last_affected":[],"package":"@materializecss/materialize","purl":"pkg:npm/%40materializecss/materialize","source":"GHSA-rg3q-jxmp-pvjj"},{"ecosystem":"npm","fixed":[],"introduced":["0"],"last_affected":["1.0.0"],"package":"materialize-css","purl":null,"source":"GHSA-rg3q-jxmp-pvjj"},{"ecosystem":"npm","fixed":[],"introduced":["0"],"last_affected":["1.0.0"],"package":"materialize-css","purl":"pkg:npm/materialize-css","source":"GHSA-rg3q-jxmp-pvjj"}],"prev":{"headline":"Materialize-css vulnerable to Cross-site Scripting in autocomplete component","id":"CVE-2019-11003"},"products":["n/a"],"published":"2019-04-08","related":[{"cvss_score":6.1,"headline":"Materialize-css vulnerable to Cross-site Scripting in tooltip component","id":"CVE-2019-11002","kev_date_added":null,"published":"2019-04-08"},{"cvss_score":6.1,"headline":"Materialize-css vulnerable to Cross-site Scripting in autocomplete component","id":"CVE-2019-11003","kev_date_added":null,"published":"2019-04-08"},{"cvss_score":5.4,"headline":"Cross-site Scripting (XSS)","id":"CVE-2022-25349","kev_date_added":null,"published":"2022-05-01"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Cross-site scripting vulnerability in Materialize allows attackers to inject malicious scripts via the Toast feature.","url":"https://insights.sbomify.com/CVE-2019-11004/"}