{"answers":{"affected":"2 open source packages ship an affected version, including ruby-openid. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-11027 in the wild and no public exploit code.","fix":"Upgrade ruby-openid to 2.9.0 or later.","what":"CVE-2019-11027 is a critical authentication bypass vulnerability in n/a, published on 10 Jun 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-11027 and fix it if it is affected.\n\nWhat it is: CVE-2019-11027 is a critical authentication bypass vulnerability in n/a, published on 10 Jun 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-11027 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ruby-openid (RubyGems): affected all versions; fixed in 2.9.0\n- ruby-openid (RubyGems): affected all versions; fixed in 2.9.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-11027/ (Markdown: https://insights.sbomify.com/CVE-2019-11027/index.md)","id":"CVE-2019-11027","markdown":"https://insights.sbomify.com/CVE-2019-11027/index.md","name":"CVE-2019-11027","record":{"aliases":["DEBIAN-CVE-2019-11027","DLA-1956-1","GHSA-fqfj-cmh6-hj49","UBUNTU-CVE-2019-11027"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby OpenID library","requires_auth":"none","summary":"Remote attackers can bypass authentication in Ruby OpenID library integrations, potentially leading to account takeover, especially in apps using example code.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"ruby-openid","vendor":"openid"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[],"description":"Ruby OpenID (aka ruby-openid) through 2.8.0 has a remotely exploitable flaw. This library is used by Rails web applications to integrate with OpenID Providers. Severity can range from medium to critical, depending on how a web application developer chose to employ the ruby-openid library. Developers who based their OpenID integration heavily on the \"example app\" provided by the project are at highest risk.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"ruby-openid SSRF via claimed_id request","id":"CVE-2019-11027","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"auth_bypass","year":"2019"},"n_packages":2,"n_references":4,"next":{"headline":"File upload in n/a","id":"CVE-2019-11028"},"packages":[{"ecosystem":"RubyGems","fixed":["2.9.0"],"introduced":["0"],"last_affected":[],"package":"ruby-openid","purl":null,"source":"GHSA-fqfj-cmh6-hj49"},{"ecosystem":"RubyGems","fixed":["2.9.0"],"introduced":["0"],"last_affected":[],"package":"ruby-openid","purl":"pkg:gem/ruby-openid","source":"GHSA-fqfj-cmh6-hj49"}],"prev":{"headline":"Denial of service in n/a","id":"CVE-2019-11026"},"products":["n/a"],"published":"2019-06-10","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Remote attackers can bypass authentication in Ruby OpenID library integrations, potentially leading to account takeover, especially in apps using example code.","url":"https://insights.sbomify.com/CVE-2019-11027/"}