# CVE-2019-11027: ruby-openid SSRF via claimed_id request

> Remote attackers can bypass authentication in Ruby OpenID library integrations, potentially leading to account takeover, especially in apps using example code.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jun 2019
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2019-11027, DLA-1956-1, GHSA-fqfj-cmh6-hj49, UBUNTU-CVE-2019-11027

## What is CVE-2019-11027?

CVE-2019-11027 is a critical authentication bypass vulnerability in n/a, published on 10 Jun 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Ruby OpenID (aka ruby-openid) through 2.8.0 has a remotely exploitable flaw. This library is used by Rails web applications to integrate with OpenID Providers. Severity can range from medium to critical, depending on how a web application developer chose to employ the ruby-openid library. Developers who based their OpenID integration heavily on the "example app" provided by the project are at highest risk.

## Which versions are affected by CVE-2019-11027?

2 open source packages ship an affected version, including ruby-openid. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ruby-openid` | RubyGems | All versions | 2.9.0 |
| `ruby-openid` | RubyGems | All versions | 2.9.0 |

Products: Openid Ruby-Openid.

## How do I fix CVE-2019-11027?

Upgrade ruby-openid to 2.9.0 or later.

## Is CVE-2019-11027 being exploited?

There is no known exploitation of CVE-2019-11027 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-11027 and fix it if it is affected.

What it is: CVE-2019-11027 is a critical authentication bypass vulnerability in n/a, published on 10 Jun 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-11027 in the wild and no public exploit code.

Affected packages and fixed versions:
- ruby-openid (RubyGems): affected all versions; fixed in 2.9.0
- ruby-openid (RubyGems): affected all versions; fixed in 2.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-11027/ (Markdown: https://insights.sbomify.com/CVE-2019-11027/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-11027
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-11027
- OSV: https://osv.dev/vulnerability/CVE-2019-11027

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-11027/
Summaries are generated and may contain mistakes; the official description above is the record.
