{"answers":{"affected":"2 open source packages ship an affected version, including org.gradle:gradle-core. It affects 2 products.","exploited":"There is no known exploitation of CVE-2019-11065 in the wild and no public exploit code.","fix":"Upgrade org.gradle:gradle-core to 5.4.0 or later.","what":"CVE-2019-11065 is a medium-severity vulnerability in Fedoraproject Fedora, published on 9 Apr 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-11065 and fix it if it is affected.\n\nWhat it is: CVE-2019-11065 is a medium-severity vulnerability in Fedoraproject Fedora, published on 9 Apr 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-11065 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.gradle:gradle-core (Maven): affected from 1.4; fixed in 5.4.0\n- org.gradle:gradle-core (Maven): affected from 1.4; fixed in 5.4.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-11065/ (Markdown: https://insights.sbomify.com/CVE-2019-11065/index.md)","id":"CVE-2019-11065","markdown":"https://insights.sbomify.com/CVE-2019-11065/index.md","name":"CVE-2019-11065","record":{"aliases":["DEBIAN-CVE-2019-11065","GHSA-pprq-4488-wgqx","UBUNTU-CVE-2019-11065"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"Gradle build tool","requires_auth":"none","summary":"Attackers can compromise dependencies via MITM when using insecure HTTP URLs in Gradle JavaScript or CoffeeScript plugins.","user_interaction":"not_required","vuln_class":"supply_chain"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"fedora","vendor":"fedoraproject"},{"product":"gradle","vendor":"gradle"}],"cvss":{"score":5.9,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[],"description":"Gradle versions from 1.4 to 5.3.1 use an insecure HTTP URL to download dependencies when the built-in JavaScript or CoffeeScript Gradle plugins are used. Dependency artifacts could have been maliciously compromised by a MITM attack against the ajax.googleapis.com web site.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Insecure transport protocol in Gradle","id":"CVE-2019-11065","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":"fedoraproject:fedora","products":["fedoraproject:fedora"],"type":"supply_chain","year":"2019"},"n_packages":2,"n_references":4,"next":{"headline":"Server-side request forgery in n/a","id":"CVE-2019-11066"},"packages":[{"ecosystem":"Maven","fixed":["5.4.0"],"introduced":["1.4"],"last_affected":[],"package":"org.gradle:gradle-core","purl":null,"source":"GHSA-pprq-4488-wgqx"},{"ecosystem":"Maven","fixed":["5.4.0"],"introduced":["1.4"],"last_affected":[],"package":"org.gradle:gradle-core","purl":"pkg:maven/org.gradle/gradle-core","source":"GHSA-pprq-4488-wgqx"}],"prev":{"headline":"A vulnerability of remote credential disclosure was discovered in Advan VD-1","id":"CVE-2019-11064"},"products":["n/a"],"published":"2019-04-09","related":[{"cvss_score":9.8,"headline":"PHP-CGI OS Command Injection","id":"CVE-2024-4577","kev_date_added":"2024-06-12","published":"2024-06-09"},{"cvss_score":9.8,"headline":"Grafana Authentication Bypass","id":"CVE-2021-39226","kev_date_added":"2022-08-25","published":"2021-10-05"},{"cvss_score":9.8,"headline":"VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow","id":"CVE-2019-5544","kev_date_added":"2021-11-03","published":"2019-12-06"},{"cvss_score":9.6,"headline":"Google Chromium V8 Type Confusion","id":"CVE-2024-4947","kev_date_added":"2024-05-20","published":"2024-05-15"},{"cvss_score":9.6,"headline":"Google Chromium Visuals Use-After-Free","id":"CVE-2024-4671","kev_date_added":"2024-05-13","published":"2024-05-09"},{"cvss_score":9.6,"headline":"Google Chromium Mojo Insufficient Data Validation","id":"CVE-2022-3075","kev_date_added":"2022-09-08","published":"2022-09-26"},{"cvss_score":9.6,"headline":"Google Chromium Indexed DB API Use-After-Free","id":"CVE-2021-30633","kev_date_added":"2021-11-03","published":"2021-10-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Attackers can compromise dependencies via MITM when using insecure HTTP URLs in Gradle JavaScript or CoffeeScript plugins.","url":"https://insights.sbomify.com/CVE-2019-11065/"}