# CVE-2019-11068: Nokogiri vulnerable to libxslt protection mechanism bypass

> Attackers can bypass security checks in libxslt by exploiting error handling flaws, allowing the loading of crafted URLs that should have been blocked.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Apr 2019
- **Updated:** 28 May 2026
- **Also known as:** ALPINE-CVE-2019-11068, DEBIAN-CVE-2019-11068, DLA-1756-1, GHSA-qxcg-xjjg-66mj, JLSEC-2026-577, MGASA-2019-0175, SUSE-SU-2019:1221-1, SUSE-SU-2019:1221-2, SUSE-SU-2019:1232-1, UBUNTU-CVE-2019-11068, USN-3947-1, openSUSE-SU-2019:1428-1, openSUSE-SU-2019:1433-1

## What is CVE-2019-11068?

CVE-2019-11068 is a critical vulnerability in Canonical Ubuntu Linux, published on 10 Apr 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

libxslt through 1.1.33 allows bypass of a protection mechanism because callers of xsltCheckRead and xsltCheckWrite permit access even upon receiving a -1 error code. xsltCheckRead can return -1 for a crafted URL that is not actually invalid and is subsequently loaded.

## Which versions are affected by CVE-2019-11068?

2 open source packages ship an affected version, including nokogiri. It affects 22 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nokogiri` | RubyGems | All versions | 1.10.3 |
| `nokogiri` | RubyGems | All versions | 1.10.3 |
| `libxslt` | SUSE:Linux Enterprise Desktop 12 SP3 | All versions | 1.1.28-17.3.1 |
| `libxslt` | SUSE:Linux Enterprise Desktop 12 SP4 | All versions | 1.1.28-17.3.1 |
| `libxslt` | SUSE:Linux Enterprise Module for Basesystem 15 | All versions | 1.1.32-3.3.1 |
| `libxslt` | SUSE:Linux Enterprise Module for Basesystem 15 SP1 | All versions | 1.1.32-3.3.1 |
| `libxslt` | SUSE:Linux Enterprise Server 12 SP3 | All versions | 1.1.28-17.3.1 |
| `libxslt` | SUSE:Linux Enterprise Server 12 SP4 | All versions | 1.1.28-17.3.1 |
| `libxslt` | SUSE:Linux Enterprise Server for SAP Applications 12 SP3 | All versions | 1.1.28-17.3.1 |
| `libxslt` | SUSE:Linux Enterprise Server for SAP Applications 12 SP4 | All versions | 1.1.28-17.3.1 |
| `libxslt` | SUSE:Linux Enterprise Software Development Kit 12 SP3 | All versions | 1.1.28-17.3.1 |
| `libxslt` | SUSE:Linux Enterprise Software Development Kit 12 SP4 | All versions | 1.1.28-17.3.1 |
| `libxslt` | openSUSE:Leap 15.0 | All versions | 1.1.32-lp150.2.3.1 |
| `libxslt-python` | openSUSE:Leap 15.0 | All versions | 1.1.32-lp150.2.3.1 |
| `libxslt` | openSUSE:Leap 15.1 | All versions | 1.1.32-lp151.3.3.1 |
| `libxslt-python` | openSUSE:Leap 15.1 | All versions | 1.1.32-lp151.3.3.1 |

Products: Canonical Ubuntu Linux, Debian Debian Linux, Fedoraproject Fedora, Netapp Active Iq Unified Manager, Netapp Cloud Backup, Netapp E-Series Santricity Management Plug-Ins, Netapp E-Series Santricity Os Controller, Netapp E-Series Santricity Storage Manager, Netapp E-Series Santricity Unified Manager, Netapp E-Series Santricity Web Services Proxy, Netapp Element Software, Netapp Hci Management Node, Netapp Oncommand Insight, Netapp Oncommand Workflow Automation, Netapp Plug-in for Symantec Netbackup, Netapp Santricity Unified Manager, Netapp Snapmanager, Netapp Solidfire, Netapp Steelstore Cloud Integrated Storage, Opensuse Leap and 2 more.

## How do I fix CVE-2019-11068?

Upgrade nokogiri to 1.10.3 or later.

## Is CVE-2019-11068 being exploited?

There is no known exploitation of CVE-2019-11068 in the wild and no public exploit code.

## Other vulnerabilities in Canonical Ubuntu Linux

- [CVE-2020-11651](https://insights.sbomify.com/CVE-2020-11651/): SaltStack Salt Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-7247](https://insights.sbomify.com/CVE-2020-7247/): OpenSMTPD Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2019-16928](https://insights.sbomify.com/CVE-2019-16928/): Exim Out-of-bounds Write (critical 9.8, exploited in the wild)
- [CVE-2018-6789](https://insights.sbomify.com/CVE-2018-6789/): Exim Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2015-2590](https://insights.sbomify.com/CVE-2015-2590/): Oracle Java SE and Java SE Embedded Remote Code Execution (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-11068 and fix it if it is affected.

What it is: CVE-2019-11068 is a critical vulnerability in Canonical Ubuntu Linux, published on 10 Apr 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-11068 in the wild and no public exploit code.

Affected packages and fixed versions:
- nokogiri (RubyGems): affected all versions; fixed in 1.10.3
- nokogiri (RubyGems): affected all versions; fixed in 1.10.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-11068/ (Markdown: https://insights.sbomify.com/CVE-2019-11068/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-11068
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-11068
- OSV: https://osv.dev/vulnerability/CVE-2019-11068

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-11068/
Summaries are generated and may contain mistakes; the official description above is the record.
