{"answers":{"affected":"2 open source packages ship an affected version, including sequelize. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-11069 in the wild and no public exploit code.","fix":"Upgrade sequelize to 5.3.0 or later.","what":"CVE-2019-11069 is a high-severity SQL injection vulnerability in n/a, published on 10 Apr 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-11069 and fix it if it is affected.\n\nWhat it is: CVE-2019-11069 is a high-severity SQL injection vulnerability in n/a, published on 10 Apr 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-11069 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- sequelize (npm): affected from 5.0.0; fixed in 5.3.0\n- sequelize (npm): affected from 5.0.0; fixed in 5.3.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-11069/ (Markdown: https://insights.sbomify.com/CVE-2019-11069/index.md)","id":"CVE-2019-11069","markdown":"https://insights.sbomify.com/CVE-2019-11069/index.md","name":"CVE-2019-11069","record":{"aliases":["GHSA-2777-2vq8-c4v4"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js ORM library","requires_auth":"none","summary":"Attackers can exploit improper string handling in Sequelize to perform SQL injection, potentially reading or modifying database contents.","user_interaction":"not_required","vuln_class":"sql_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"sequelize","vendor":"sequelizejs"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N","version":"3.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"Sequelize version 5 before 5.3.0 does not properly ensure that standard conforming strings are used.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"SQL Injection in sequelize","id":"CVE-2019-11069","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"sql_injection","year":"2019"},"n_packages":2,"n_references":4,"next":{"headline":"Information disclosure in n/a","id":"CVE-2019-11070"},"packages":[{"ecosystem":"npm","fixed":["5.3.0"],"introduced":["5.0.0"],"last_affected":[],"package":"sequelize","purl":null,"source":"GHSA-2777-2vq8-c4v4"},{"ecosystem":"npm","fixed":["5.3.0"],"introduced":["5.0.0"],"last_affected":[],"package":"sequelize","purl":"pkg:npm/sequelize","source":"GHSA-2777-2vq8-c4v4"}],"prev":{"headline":"Nokogiri vulnerable to libxslt protection mechanism bypass","id":"CVE-2019-11068"},"products":["n/a"],"published":"2019-04-10","related":[{"cvss_score":10,"headline":"SQL Injection via replacements in sequelize","id":"CVE-2023-25813","kev_date_added":null,"published":"2023-02-22"},{"cvss_score":10,"headline":"Sequalize - Default support for “raw attributes” when using parentheses","id":"CVE-2023-22578","kev_date_added":null,"published":"2023-02-16"},{"cvss_score":9.9,"headline":"Sequalize - Unsafe fall-through in getWhereConditions","id":"CVE-2023-22579","kev_date_added":null,"published":"2023-02-16"},{"cvss_score":9.8,"headline":"SQL Injection in sequelize","id":"CVE-2019-10749","kev_date_added":null,"published":"2019-10-29"},{"cvss_score":9.8,"headline":"SQL Injection in sequelize","id":"CVE-2019-10748","kev_date_added":null,"published":"2019-10-28"},{"cvss_score":9.8,"headline":"SQL Injection in sequelize","id":"CVE-2019-10752","kev_date_added":null,"published":"2019-10-17"},{"cvss_score":9.8,"headline":"SQL Injection in sequelize","id":"CVE-2016-10550","kev_date_added":null,"published":"2018-05-31"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Attackers can exploit improper string handling in Sequelize to perform SQL injection, potentially reading or modifying database contents.","url":"https://insights.sbomify.com/CVE-2019-11069/"}