# CVE-2019-11202: Rancher Recreates Default User With Known Password Despite Deletion

> Attackers can gain admin access by logging in with recreated default credentials after a restart, requiring deactivation instead of deletion.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Jul 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-xh8x-j8h3-m5ph, GO-2024-2784

## What is CVE-2019-11202?

CVE-2019-11202 is a critical vulnerability in n/a, published on 30 Jul 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered that affects the following versions of Rancher: v2.0.0 through v2.0.13, v2.1.0 through v2.1.8, and v2.2.0 through 2.2.1. When Rancher starts for the first time, it creates a default admin user with a well-known password. After initial setup, the Rancher administrator may choose to delete this default admin user. If Rancher is restarted, the default admin user will be recreated with the well-known default password. An attacker could exploit this by logging in with the default admin credentials. This can be mitigated by deactivating the default admin user rather than completing deleting them.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2019-11202?

7 open source packages ship an affected version, including github.com/rancher/rancher. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/rancher/rancher` | Go | From 2.0.0 to 2.0.13 | None |
| `github.com/rancher/rancher` | Go | From 2.0.0 to 2.0.13 | None |
| `github.com/rancher/rancher` | Go | From 2.0.0+incompatible | 2.2.2+incompatible |
| `github.com/rancher/rancher` | Go | From 2.1.0 to 2.1.8 | None |
| `github.com/rancher/rancher` | Go | From 2.1.0 to 2.1.8 | None |
| `github.com/rancher/rancher` | Go | From 2.2.0 | 2.2.2 |
| `github.com/rancher/rancher` | Go | From 2.2.0 | 2.2.2 |

Products: Suse Rancher.

## How do I fix CVE-2019-11202?

Upgrade github.com/rancher/rancher to a fixed version for your release line: 2.2.2+incompatible or 2.2.2.

## Is CVE-2019-11202 being exploited?

There is no known exploitation of CVE-2019-11202 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2023-22647](https://insights.sbomify.com/CVE-2023-22647/): Rancher vulnerable to Privilege Escalation via manipulation of Secrets (critical 9.9)
- [CVE-2023-22651](https://insights.sbomify.com/CVE-2023-22651/): Rancher Webhook is misconfigured during upgrade process (critical 9.9)
- [CVE-2022-43757](https://insights.sbomify.com/CVE-2022-43757/): Rancher: Exposure of sensitive fields (critical 9.9)
- [CVE-2021-36782](https://insights.sbomify.com/CVE-2021-36782/): Rancher: Plaintext storage and exposure of credentials in Rancher API and cluster.management.cattle.io object (critical 9.9)
- [CVE-2021-36783](https://insights.sbomify.com/CVE-2021-36783/): Rancher: Failure to properly sanitize credentials in cluster template answers (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-11202 and fix it if it is affected.

What it is: CVE-2019-11202 is a critical vulnerability in n/a, published on 30 Jul 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-11202 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/rancher/rancher (Go): affected from 2.0.0 up to 2.0.13; no fix listed
- github.com/rancher/rancher (Go): affected from 2.0.0 up to 2.0.13; no fix listed
- github.com/rancher/rancher (Go): affected from 2.0.0+incompatible; fixed in 2.2.2+incompatible
- github.com/rancher/rancher (Go): affected from 2.1.0 up to 2.1.8; no fix listed
- github.com/rancher/rancher (Go): affected from 2.1.0 up to 2.1.8; no fix listed
- github.com/rancher/rancher (Go): affected from 2.2.0; fixed in 2.2.2
- github.com/rancher/rancher (Go): affected from 2.2.0; fixed in 2.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-11202/ (Markdown: https://insights.sbomify.com/CVE-2019-11202/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-11202
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-11202
- OSV: https://osv.dev/vulnerability/CVE-2019-11202

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-11202/
Summaries are generated and may contain mistakes; the official description above is the record.
