CVE-2019-11247 Kubernetes kube-apiserver allows access to custom resources via wrong scope
Attackers with namespace access can manipulate cluster-scoped resources due to incorrect authorization scope enforcement in the Kubernetes API server.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2019-11247?
CVE-2019-11247 is a medium-severity missing authorization vulnerability in Kubernetes Kubernetes, published on 29 Aug 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
The Kubernetes kube-apiserver mistakenly allows access to a cluster-scoped custom resource if the request is made as if the resource were namespaced. Authorizations for the resource accessed in this manner are enforced using roles and role bindings within the namespace, meaning that a user with access only to a resource in one namespace could create, view update or delete the cluster-scoped resource (according to their namespace role privileges). Kubernetes affected versions include versions prior to 1.13.9, versions prior to 1.14.5, versions prior to 1.15.2, and versions 1.7, 1.8, 1.9, 1.10, 1.11, 1.12.
Which versions are affected by CVE-2019-11247?
6 open source packages ship an affected version, including k8s.io/apiextensions-apiserver. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
k8s.io/apiextensions-apiserver Go | From 0.14.0 | 0.14.5 |
k8s.io/apiextensions-apiserver Go | From 0.14.0 | 0.14.5 |
k8s.io/apiextensions-apiserver Go | From 0.15.0 | 0.15.2 |
k8s.io/apiextensions-apiserver Go | From 0.15.0 | 0.15.2 |
k8s.io/apiextensions-apiserver Go | From 0.7.0 | 0.13.9 |
k8s.io/apiextensions-apiserver Go | From 0.7.0 | 0.13.9 |
Linux distribution packages (8)
openshift Red Hat:openshift:4.1::el7 | All versions | 0:4.1.10-201908060758.git.0.d81afa6.el7 |
openshift-clients Red Hat:openshift:4.1::el7 | All versions | 0:4.1.10-201908060758.git.0.d81afa6.el7 |
openshift-clients-redistributable Red Hat:openshift:4.1::el7 | All versions | 0:4.1.10-201908060758.git.0.d81afa6.el7 |
openshift-hyperkube Red Hat:openshift:4.1::el7 | All versions | 0:4.1.10-201908060758.git.0.d81afa6.el7 |
openshift Red Hat:openshift:4.1::el8 | All versions | 0:4.1.10-201908060758.git.0.d81afa6.el8 |
openshift-clients Red Hat:openshift:4.1::el8 | All versions | 0:4.1.10-201908060758.git.0.d81afa6.el8 |
openshift-clients-redistributable Red Hat:openshift:4.1::el8 | All versions | 0:4.1.10-201908060758.git.0.d81afa6.el8 |
openshift-hyperkube Red Hat:openshift:4.1::el8 | All versions | 0:4.1.10-201908060758.git.0.d81afa6.el8 |
Products include Kubernetes Kubernetes, Redhat Openshift Container Platform.
How do I fix CVE-2019-11247?
Upgrade k8s.io/apiextensions-apiserver to a fixed version for your release line: 0.14.5, 0.15.2 or 0.13.9.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2019-11247 being exploited?
There is no known exploitation of CVE-2019-11247 in the wild and no public exploit code.
Other vulnerabilities in Kubernetes Kubernetes
- CVE-2018-1002105 Privilege Escalation in Kubernetes
- CVE-2017-1000056 Kubernetes Privilege Escalation
- CVE-2016-1906 Authorization bypass in Openshift
- CVE-2023-3676 Kubernetes - Windows nodes - Insufficient input sanitization leads to privilege escalation
- CVE-2023-3955 Kubernetes - Windows nodes - Insufficient input sanitization leads to privilege escalation
Sources
Also known as DEBIAN-CVE-2019-11247, GHSA-fp37-c92q-4pwq, RHSA-2019:2504.