# CVE-2019-11247: Kubernetes kube-apiserver allows access to custom resources via wrong scope

> Attackers with namespace access can manipulate cluster-scoped resources due to incorrect authorization scope enforcement in the Kubernetes API server.

- **Severity:** Medium 5.0 (`CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Aug 2019
- **Updated:** 16 Sep 2024
- **Also known as:** DEBIAN-CVE-2019-11247, GHSA-fp37-c92q-4pwq, RHSA-2019:2504

## What is CVE-2019-11247?

CVE-2019-11247 is a medium-severity missing authorization vulnerability in Kubernetes Kubernetes, published on 29 Aug 2019. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The Kubernetes kube-apiserver mistakenly allows access to a cluster-scoped custom resource if the request is made as if the resource were namespaced. Authorizations for the resource accessed in this manner are enforced using roles and role bindings within the namespace, meaning that a user with access only to a resource in one namespace could create, view update or delete the cluster-scoped resource (according to their namespace role privileges). Kubernetes affected versions include versions prior to 1.13.9, versions prior to 1.14.5, versions prior to 1.15.2, and versions 1.7, 1.8, 1.9, 1.10, 1.11, 1.12.

Weakness: CWE-863 (Incorrect Authorization), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2019-11247?

6 open source packages ship an affected version, including k8s.io/apiextensions-apiserver. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `k8s.io/apiextensions-apiserver` | Go | From 0.14.0 | 0.14.5 |
| `k8s.io/apiextensions-apiserver` | Go | From 0.14.0 | 0.14.5 |
| `k8s.io/apiextensions-apiserver` | Go | From 0.15.0 | 0.15.2 |
| `k8s.io/apiextensions-apiserver` | Go | From 0.15.0 | 0.15.2 |
| `k8s.io/apiextensions-apiserver` | Go | From 0.7.0 | 0.13.9 |
| `k8s.io/apiextensions-apiserver` | Go | From 0.7.0 | 0.13.9 |
| `openshift` | Red Hat:openshift:4.1::el7 | All versions | 0:4.1.10-201908060758.git.0.d81afa6.el7 |
| `openshift-clients` | Red Hat:openshift:4.1::el7 | All versions | 0:4.1.10-201908060758.git.0.d81afa6.el7 |
| `openshift-clients-redistributable` | Red Hat:openshift:4.1::el7 | All versions | 0:4.1.10-201908060758.git.0.d81afa6.el7 |
| `openshift-hyperkube` | Red Hat:openshift:4.1::el7 | All versions | 0:4.1.10-201908060758.git.0.d81afa6.el7 |
| `openshift` | Red Hat:openshift:4.1::el8 | All versions | 0:4.1.10-201908060758.git.0.d81afa6.el8 |
| `openshift-clients` | Red Hat:openshift:4.1::el8 | All versions | 0:4.1.10-201908060758.git.0.d81afa6.el8 |
| `openshift-clients-redistributable` | Red Hat:openshift:4.1::el8 | All versions | 0:4.1.10-201908060758.git.0.d81afa6.el8 |
| `openshift-hyperkube` | Red Hat:openshift:4.1::el8 | All versions | 0:4.1.10-201908060758.git.0.d81afa6.el8 |

Products: Kubernetes Kubernetes, Redhat Openshift Container Platform.

## How do I fix CVE-2019-11247?

Upgrade k8s.io/apiextensions-apiserver to a fixed version for your release line: 0.14.5, 0.15.2 or 0.13.9.

## Is CVE-2019-11247 being exploited?

There is no known exploitation of CVE-2019-11247 in the wild and no public exploit code.

## Other vulnerabilities in Kubernetes Kubernetes

- [CVE-2018-1002105](https://insights.sbomify.com/CVE-2018-1002105/): Privilege Escalation in Kubernetes (critical 9.8)
- [CVE-2017-1000056](https://insights.sbomify.com/CVE-2017-1000056/): Kubernetes Privilege Escalation (critical 9.8)
- [CVE-2016-1906](https://insights.sbomify.com/CVE-2016-1906/): Authorization bypass in Openshift (critical 9.8)
- [CVE-2023-3676](https://insights.sbomify.com/CVE-2023-3676/): Kubernetes - Windows nodes - Insufficient input sanitization leads to privilege escalation (high 8.8)
- [CVE-2023-3955](https://insights.sbomify.com/CVE-2023-3955/): Kubernetes - Windows nodes - Insufficient input sanitization leads to privilege escalation (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-11247 and fix it if it is affected.

What it is: CVE-2019-11247 is a medium-severity missing authorization vulnerability in Kubernetes Kubernetes, published on 29 Aug 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-11247 in the wild and no public exploit code.

Affected packages and fixed versions:
- k8s.io/apiextensions-apiserver (Go): affected from 0.14.0; fixed in 0.14.5
- k8s.io/apiextensions-apiserver (Go): affected from 0.14.0; fixed in 0.14.5
- k8s.io/apiextensions-apiserver (Go): affected from 0.15.0; fixed in 0.15.2
- k8s.io/apiextensions-apiserver (Go): affected from 0.15.0; fixed in 0.15.2
- k8s.io/apiextensions-apiserver (Go): affected from 0.7.0; fixed in 0.13.9
- k8s.io/apiextensions-apiserver (Go): affected from 0.7.0; fixed in 0.13.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-11247/ (Markdown: https://insights.sbomify.com/CVE-2019-11247/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-11247
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-11247
- OSV: https://osv.dev/vulnerability/CVE-2019-11247

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-11247/
Summaries are generated and may contain mistakes; the official description above is the record.
