# CVE-2019-11251: kubectl cp allows symlink directory traversal

> A malicious container can use symlinks in kubectl cp to write files outside the destination directory, allowing attackers to modify arbitrary files on the host.

- **Severity:** Medium 4.8 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 3 Feb 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-6qfg-8799-r575, GO-2022-0802, RHSA-2019:3266

## What is CVE-2019-11251?

CVE-2019-11251 is a medium-severity path traversal vulnerability in Kubernetes Kubernetes, published on 3 Feb 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

The Kubernetes kubectl cp command in versions 1.1-1.12, and versions prior to 1.13.11, 1.14.7, and 1.15.4 allows a combination of two symlinks provided by tar output of a malicious container to place a file outside of the destination directory specified in the kubectl cp invocation. This could be used to allow an attacker to place a nefarious file using a symlink, outside of the destination tree.

Weakness: CWE-59 (Improper Link Resolution Before File Access), CWE-61 (UNIX Symbolic Link (Symlink) Following)

## Which versions are affected by CVE-2019-11251?

7 open source packages ship an affected version, including k8s.io/kubernetes. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `k8s.io/kubernetes` | Go | From 1.13.10 | 1.13.11, 1.14.7, 1.16.0 |
| `k8s.io/kubernetes` | Go | From 1.13.10 | 1.13.11 |
| `k8s.io/kubernetes` | Go | From 1.13.10 | 1.13.11 |
| `k8s.io/kubernetes` | Go | From 1.14.6 | 1.14.7 |
| `k8s.io/kubernetes` | Go | From 1.14.6 | 1.14.7 |
| `k8s.io/kubernetes` | Go | From 1.15.3 | 1.16.0 |
| `k8s.io/kubernetes` | Go | From 1.15.3 | 1.16.0 |
| `openshift` | Red Hat:openshift:4.1::el7 | All versions | 0:4.1.21-201910220952.git.0.493dbf6.el7 |
| `openshift-clients` | Red Hat:openshift:4.1::el7 | All versions | 0:4.1.21-201910220952.git.0.493dbf6.el7 |
| `openshift-clients-redistributable` | Red Hat:openshift:4.1::el7 | All versions | 0:4.1.21-201910220952.git.0.493dbf6.el7 |
| `openshift-hyperkube` | Red Hat:openshift:4.1::el7 | All versions | 0:4.1.21-201910220952.git.0.493dbf6.el7 |
| `openshift` | Red Hat:openshift:4.1::el8 | All versions | 0:4.1.21-201910220952.git.0.493dbf6.el8 |
| `openshift-clients` | Red Hat:openshift:4.1::el8 | All versions | 0:4.1.21-201910220952.git.0.493dbf6.el8 |
| `openshift-clients-redistributable` | Red Hat:openshift:4.1::el8 | All versions | 0:4.1.21-201910220952.git.0.493dbf6.el8 |
| `openshift-hyperkube` | Red Hat:openshift:4.1::el8 | All versions | 0:4.1.21-201910220952.git.0.493dbf6.el8 |

Products: Kubernetes Kubernetes.

## How do I fix CVE-2019-11251?

Upgrade k8s.io/kubernetes to a fixed version for your release line: 1.13.11, 1.14.7 or 1.16.0.

## Is CVE-2019-11251 being exploited?

There is no known exploitation of CVE-2019-11251 in the wild and no public exploit code.

## Other vulnerabilities in Kubernetes Kubernetes

- [CVE-2018-1002105](https://insights.sbomify.com/CVE-2018-1002105/): Privilege Escalation in Kubernetes (critical 9.8)
- [CVE-2017-1000056](https://insights.sbomify.com/CVE-2017-1000056/): Kubernetes Privilege Escalation (critical 9.8)
- [CVE-2016-1906](https://insights.sbomify.com/CVE-2016-1906/): Authorization bypass in Openshift (critical 9.8)
- [CVE-2023-3676](https://insights.sbomify.com/CVE-2023-3676/): Kubernetes - Windows nodes - Insufficient input sanitization leads to privilege escalation (high 8.8)
- [CVE-2023-3955](https://insights.sbomify.com/CVE-2023-3955/): Kubernetes - Windows nodes - Insufficient input sanitization leads to privilege escalation (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-11251 and fix it if it is affected.

What it is: CVE-2019-11251 is a medium-severity path traversal vulnerability in Kubernetes Kubernetes, published on 3 Feb 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-11251 in the wild and no public exploit code.

Affected packages and fixed versions:
- k8s.io/kubernetes (Go): affected from 1.13.10; fixed in 1.13.11, 1.14.7, 1.16.0
- k8s.io/kubernetes (Go): affected from 1.13.10; fixed in 1.13.11
- k8s.io/kubernetes (Go): affected from 1.13.10; fixed in 1.13.11
- k8s.io/kubernetes (Go): affected from 1.14.6; fixed in 1.14.7
- k8s.io/kubernetes (Go): affected from 1.14.6; fixed in 1.14.7
- k8s.io/kubernetes (Go): affected from 1.15.3; fixed in 1.16.0
- k8s.io/kubernetes (Go): affected from 1.15.3; fixed in 1.16.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-11251/ (Markdown: https://insights.sbomify.com/CVE-2019-11251/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-11251
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-11251
- OSV: https://osv.dev/vulnerability/CVE-2019-11251

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-11251/
Summaries are generated and may contain mistakes; the official description above is the record.
