# CVE-2019-11254: Kubernetes API Server denial of service vulnerability from malicious YAML payloads

> An authorized user can cause the Kubernetes API Server to consume excessive CPU resources by sending malicious YAML payloads, leading to denial of service.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Apr 2020
- **Updated:** 16 Sep 2024
- **Also known as:** AZL-41568, AZL-44445, AZL-44808, AZL-44904, CLEANSTART-2026-GX38111, DEBIAN-CVE-2019-11254, GHSA-wxc4-f4m6-wwqv, GO-2020-0036, openSUSE-SU-2024:11911-1

## What is CVE-2019-11254?

CVE-2019-11254 is a medium-severity denial of service vulnerability in Kubernetes Kubernetes, published on 1 Apr 2020. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The Kubernetes API Server component in versions 1.1-1.14, and versions prior to 1.15.10, 1.16.7 and 1.17.3 allows an authorized user who sends malicious YAML payloads to cause the kube-apiserver to consume excessive CPU cycles while parsing YAML.

Weakness: CWE-1050 (Excessive Platform Resource Consumption within a Loop)

## Which versions are affected by CVE-2019-11254?

6 open source packages ship an affected version, including github.com/go-yaml/yaml and gopkg.in/yaml.v2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/go-yaml/yaml` | Go | All versions | None |
| `github.com/go-yaml/yaml` | Go | All versions to 2.1.0 | None |
| `github.com/go-yaml/yaml` | Go | All versions to 2.1.0 | None |
| `gopkg.in/yaml.v2` | Go | All versions | 2.2.8 |
| `gopkg.in/yaml.v2` | Go | All versions | 2.2.8 |
| `gopkg.in/yaml.v2` | Go | All versions | 2.2.8 |
| `etcd` | openSUSE:Tumbleweed | All versions | 3.5.2-1.1 |

Products: Kubernetes Kubernetes.

## How do I fix CVE-2019-11254?

Upgrade to a fixed version.

## Is CVE-2019-11254 being exploited?

There is no known exploitation of CVE-2019-11254 in the wild and no public exploit code.

## Other vulnerabilities in Kubernetes Kubernetes

- [CVE-2018-1002105](https://insights.sbomify.com/CVE-2018-1002105/): Privilege Escalation in Kubernetes (critical 9.8)
- [CVE-2017-1000056](https://insights.sbomify.com/CVE-2017-1000056/): Kubernetes Privilege Escalation (critical 9.8)
- [CVE-2016-1906](https://insights.sbomify.com/CVE-2016-1906/): Authorization bypass in Openshift (critical 9.8)
- [CVE-2023-3676](https://insights.sbomify.com/CVE-2023-3676/): Kubernetes - Windows nodes - Insufficient input sanitization leads to privilege escalation (high 8.8)
- [CVE-2023-3955](https://insights.sbomify.com/CVE-2023-3955/): Kubernetes - Windows nodes - Insufficient input sanitization leads to privilege escalation (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-11254 and fix it if it is affected.

What it is: CVE-2019-11254 is a medium-severity denial of service vulnerability in Kubernetes Kubernetes, published on 1 Apr 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-11254 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/go-yaml/yaml (Go): affected all versions; no fix listed
- github.com/go-yaml/yaml (Go): affected all versions up to 2.1.0; no fix listed
- github.com/go-yaml/yaml (Go): affected all versions up to 2.1.0; no fix listed
- gopkg.in/yaml.v2 (Go): affected all versions; fixed in 2.2.8
- gopkg.in/yaml.v2 (Go): affected all versions; fixed in 2.2.8
- gopkg.in/yaml.v2 (Go): affected all versions; fixed in 2.2.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-11254/ (Markdown: https://insights.sbomify.com/CVE-2019-11254/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-11254
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-11254
- OSV: https://osv.dev/vulnerability/CVE-2019-11254

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-11254/
Summaries are generated and may contain mistakes; the official description above is the record.
