# CVE-2019-11272: PlaintextPasswordEncoder authenticates encoded passwords that are null

> Attackers can authenticate as users with null encoded passwords when using PlaintextPasswordEncoder, leading to account takeover.

- **Severity:** High 7.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Jun 2019
- **Updated:** 16 Sep 2024
- **Also known as:** DLA-1848-1, GHSA-v33x-prhc-gph5

## What is CVE-2019-11272?

CVE-2019-11272 is a high-severity authentication bypass vulnerability in Debian Debian Linux, published on 26 Jun 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Spring Security, versions 4.2.x up to 4.2.12, and older unsupported versions support plain text passwords using PlaintextPasswordEncoder. If an application using an affected version of Spring Security is leveraging PlaintextPasswordEncoder and a user has a null encoded password, a malicious user (or attacker) can authenticate using a password of "null".

Weakness: CWE-522 (Insufficiently Protected Credentials), CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2019-11272?

4 open source packages ship an affected version, including org.springframework.security:spring-security-cas and org.springframework.security:spring-security-core. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.springframework.security:spring-security-cas` | Maven | All versions | 4.2.13.RELEASE |
| `org.springframework.security:spring-security-cas` | Maven | All versions | 4.2.13.RELEASE |
| `org.springframework.security:spring-security-core` | Maven | All versions | 4.2.13 |
| `org.springframework.security:spring-security-core` | Maven | All versions | 4.2.13 |

Products: Debian Debian Linux, Vmware Spring Security.

## How do I fix CVE-2019-11272?

Upgrade org.springframework.security:spring-security-cas to 4.2.13.RELEASE or later.

## Is CVE-2019-11272 being exploited?

There is no known exploitation of CVE-2019-11272 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-11272 and fix it if it is affected.

What it is: CVE-2019-11272 is a high-severity authentication bypass vulnerability in Debian Debian Linux, published on 26 Jun 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-11272 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.springframework.security:spring-security-cas (Maven): affected all versions; fixed in 4.2.13.RELEASE
- org.springframework.security:spring-security-cas (Maven): affected all versions; fixed in 4.2.13.RELEASE
- org.springframework.security:spring-security-core (Maven): affected all versions; fixed in 4.2.13
- org.springframework.security:spring-security-core (Maven): affected all versions; fixed in 4.2.13

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-11272/ (Markdown: https://insights.sbomify.com/CVE-2019-11272/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-11272
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-11272
- OSV: https://osv.dev/vulnerability/CVE-2019-11272

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-11272/
Summaries are generated and may contain mistakes; the official description above is the record.
