# CVE-2019-11287: RabbitMQ Web Management Plugin DoS via heap overflow

> An attacker can crash the RabbitMQ server by sending a malicious HTTP header to the web management plugin, causing a heap overflow.

- **Severity:** Medium 4.5 (`CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 22 Nov 2019
- **Updated:** 16 Sep 2024
- **Also known as:** DEBIAN-CVE-2019-11287, GHSA-hrfh-7j5f-8ccr, UBUNTU-CVE-2019-11287

## What is CVE-2019-11287?

CVE-2019-11287 is a medium-severity denial of service vulnerability in Broadcom Rabbitmq Server, published on 22 Nov 2019. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Pivotal RabbitMQ, versions 3.7.x prior to 3.7.21 and 3.8.x prior to 3.8.1, and RabbitMQ for Pivotal Platform, 1.16.x versions prior to 1.16.7 and 1.17.x versions prior to 1.17.4, contain a web management plugin that is vulnerable to a denial of service attack. The "X-Reason" HTTP Header can be leveraged to insert a malicious Erlang format string that will expand and consume the heap, resulting in the server crashing.

Weakness: CWE-134 (Use of Externally-Controlled Format String), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2019-11287?

8 open source packages ship an affected version, including RabbitMQ. It affects 5 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `RabbitMQ` | Hex | All versions | 1.16.7 |
| `RabbitMQ` | Hex | All versions | 1.16.7 |
| `RabbitMQ` | Hex | From 1.17.0 | 1.17.4 |
| `RabbitMQ` | Hex | From 1.17.0 | 1.17.4 |
| `RabbitMQ` | Hex | From 3.7.0 | 3.7.21 |
| `RabbitMQ` | Hex | From 3.7.0 | 3.7.21 |
| `RabbitMQ` | Hex | From 3.8.0 | 3.8.1 |
| `RabbitMQ` | Hex | From 3.8.0 | 3.8.1 |

Products: Broadcom Rabbitmq Server, Debian Debian Linux, Fedoraproject Fedora, Pivotal Software Rabbitmq, Redhat Openstack.

## How do I fix CVE-2019-11287?

Upgrade RabbitMQ to a fixed version for your release line: 1.16.7, 1.17.4, 3.7.21 or 3.8.1.

## Is CVE-2019-11287 being exploited?

There is no known exploitation of CVE-2019-11287 in the wild and no public exploit code.

Public exploit code:

- CVE-2019-11287: DoS via Heap Overflow in RabbitMQ Web Management Plugin (github_poc): https://github.com/mbadanoiu/CVE-2019-11287

## Other vulnerabilities in Broadcom Rabbitmq Server

- [CVE-2016-9877](https://insights.sbomify.com/CVE-2016-9877/): Auth bypass in Pivotal RabbitMQ 3.x before 3.5.8 and 3.6.x before 3.6.6; RabbitMQ for PCF 1.5.x before 1.5.20, 1.6.x before 1.6.12 and 1.7.x before 1.7.7 (critical 9.8)
- [CVE-2026-67404](https://insights.sbomify.com/CVE-2026-67404/): RabbitMQ: OAuth2 silent verify_none fallback for JWKS fetch (critical 9.2)
- [CVE-2026-67231](https://insights.sbomify.com/CVE-2026-67231/): RabbitMQ: Trust-store whitelist by Issuer+Serial only (critical 9.1)
- [CVE-2026-57219](https://insights.sbomify.com/CVE-2026-57219/): Information disclosure in rabbitmq-server (high 8.7)
- [CVE-2026-67236](https://insights.sbomify.com/CVE-2026-67236/): RabbitMQ: Plaintext username:password stored in an insecure cookie after successful POST /login (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-11287 and fix it if it is affected.

What it is: CVE-2019-11287 is a medium-severity denial of service vulnerability in Broadcom Rabbitmq Server, published on 22 Nov 2019. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-11287 in the wild and no public exploit code.

Affected packages and fixed versions:
- RabbitMQ (Hex): affected all versions; fixed in 1.16.7
- RabbitMQ (Hex): affected all versions; fixed in 1.16.7
- RabbitMQ (Hex): affected from 1.17.0; fixed in 1.17.4
- RabbitMQ (Hex): affected from 1.17.0; fixed in 1.17.4
- RabbitMQ (Hex): affected from 3.7.0; fixed in 3.7.21
- RabbitMQ (Hex): affected from 3.7.0; fixed in 3.7.21
- RabbitMQ (Hex): affected from 3.8.0; fixed in 3.8.1
- RabbitMQ (Hex): affected from 3.8.0; fixed in 3.8.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-11287/ (Markdown: https://insights.sbomify.com/CVE-2019-11287/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-11287
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-11287
- OSV: https://osv.dev/vulnerability/CVE-2019-11287

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-11287/
Summaries are generated and may contain mistakes; the official description above is the record.
