# CVE-2019-11289: A forged route service request using an invalid nonce can cause the gorouter to panic and crash

> A remote unauthenticated attacker can crash the Cloud Foundry Gorouter by sending a forged route service request with an invalid nonce.

- **Severity:** High 8.6 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Nov 2019
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-5796-p3m6-9qj4, GO-2021-0102

## What is CVE-2019-11289?

CVE-2019-11289 is a high-severity denial of service vulnerability in Cloud Foundry Routing, published on 19 Nov 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Cloud Foundry Routing, all versions before 0.193.0, does not properly validate nonce input. A remote unauthenticated malicious user could forge an HTTP route service request using an invalid nonce that will cause the Gorouter to crash.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2019-11289?

4 open source packages ship an affected version, including code.cloudfoundry.org/gorouter and github.com/cloudfoundry/gorouter. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `code.cloudfoundry.org/gorouter` | Go | All versions | 0.0.0-20191101214924-b1b5c44e050f |
| `code.cloudfoundry.org/gorouter` | Go | All versions | 0.0.0-20191101214924-b1b5c44e050f |
| `code.cloudfoundry.org/gorouter` | Go | All versions | 0.0.0-20191101214924-b1b5c44e050f |
| `github.com/cloudfoundry/gorouter` | Go | All versions | 0.0.0-20191101214924-b1b5c44e050f |

Products: Cloudfoundry Cf-Deployment, Cloudfoundry Routing-Release.

## How do I fix CVE-2019-11289?

Upgrade code.cloudfoundry.org/gorouter to 0.0.0-20191101214924-b1b5c44e050f or later.

## Is CVE-2019-11289 being exploited?

There is no known exploitation of CVE-2019-11289 in the wild and no public exploit code.

## Other vulnerabilities in Cloud Foundry Routing

- [CVE-2022-31733](https://insights.sbomify.com/CVE-2022-31733/): Auth bypass in Cloud Foundry Diego and CF Deployment (critical 9.1)
- [CVE-2020-5402](https://insights.sbomify.com/CVE-2020-5402/): UAA fails to check the state parameter when authenticating with external IDPs (high 8.8)
- [CVE-2019-11293](https://insights.sbomify.com/CVE-2019-11293/): UAA logs all query parameters with debug logging level (high 8.8)
- [CVE-2019-11290](https://insights.sbomify.com/CVE-2019-11290/): Cloud Foundry UAA logs query parameters in tomcat access file (high 8.8)
- [CVE-2019-11283](https://insights.sbomify.com/CVE-2019-11283/): Password leak in smbdriver logs (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-11289 and fix it if it is affected.

What it is: CVE-2019-11289 is a high-severity denial of service vulnerability in Cloud Foundry Routing, published on 19 Nov 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-11289 in the wild and no public exploit code.

Affected packages and fixed versions:
- code.cloudfoundry.org/gorouter (Go): affected all versions; fixed in 0.0.0-20191101214924-b1b5c44e050f
- code.cloudfoundry.org/gorouter (Go): affected all versions; fixed in 0.0.0-20191101214924-b1b5c44e050f
- code.cloudfoundry.org/gorouter (Go): affected all versions; fixed in 0.0.0-20191101214924-b1b5c44e050f
- github.com/cloudfoundry/gorouter (Go): affected all versions; fixed in 0.0.0-20191101214924-b1b5c44e050f

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-11289/ (Markdown: https://insights.sbomify.com/CVE-2019-11289/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-11289
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-11289
- OSV: https://osv.dev/vulnerability/CVE-2019-11289

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-11289/
Summaries are generated and may contain mistakes; the official description above is the record.
