CVE-2019-11291 RabbitMQ XSS attack via federation and shovel endpoints
An authenticated administrator can inject scripts via federation or shovel endpoints to access sensitive virtual host and policy information.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2019-11291?
CVE-2019-11291 is a low-severity cross-site scripting vulnerability in Broadcom Rabbitmq Server, published on 22 Nov 2019. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Official description
Pivotal RabbitMQ, 3.7 versions prior to v3.7.20 and 3.8 version prior to v3.8.1, and RabbitMQ for PCF, 1.16.x versions prior to 1.16.7 and 1.17.x versions prior to 1.17.4, contain two endpoints, federation and shovel, which do not properly sanitize user input. A remote authenticated malicious user with administrative access could craft a cross site scripting attack via the vhost or node name fields that could grant access to virtual hosts and policy management information.
Weakness: CWE-79
Which versions are affected by CVE-2019-11291?
4 open source packages ship an affected version, including rabbit_common. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
rabbit_common Hex | From 3.7.0 | 3.7.20 |
rabbit_common Hex | From 3.7.0 | 3.7.20 |
rabbit_common Hex | From 3.8.0 | 3.8.1 |
rabbit_common Hex | From 3.8.0 | 3.8.1 |
Linux distribution packages (1)
rabbitmq-server Red Hat:openstack:15::el8 | All versions | 0:3.7.23-2.el8ost |
Products include Broadcom Rabbitmq Server, Redhat Openstack, Vmware Rabbitmq.
How do I fix CVE-2019-11291?
Upgrade rabbit_common to a fixed version for your release line: 3.7.20 or 3.8.1.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2019-11291 being exploited?
There is no known exploitation of CVE-2019-11291 in the wild and no public exploit code.
Other vulnerabilities in Broadcom Rabbitmq Server
- CVE-2016-9877 Auth bypass in Pivotal RabbitMQ 3.x before 3.5.8 and 3.6.x before 3.6.6; RabbitMQ for PCF 1.5.x before 1.5.20, 1.6.x before 1.6.12 and 1.7.x before 1.7.7
- CVE-2026-67404 RabbitMQ: OAuth2 silent verify_none fallback for JWKS fetch
- CVE-2026-67231 RabbitMQ: Trust-store whitelist by Issuer+Serial only
- CVE-2026-57219 Information disclosure in rabbitmq-server
- CVE-2026-67236 RabbitMQ: Plaintext username:password stored in an insecure cookie after successful POST /login
Sources
Also known as DEBIAN-CVE-2019-11291, GHSA-9pf7-f47q-mwpq, RHSA-2020:0553.