# CVE-2019-11291: RabbitMQ XSS attack via federation and shovel endpoints

> An authenticated administrator can inject scripts via federation or shovel endpoints to access sensitive virtual host and policy information.

- **Severity:** Low 3.1 (`CVSS:3.0/AV:N/AC:H/PR:H/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 22 Nov 2019
- **Updated:** 17 Sep 2024
- **Also known as:** DEBIAN-CVE-2019-11291, GHSA-9pf7-f47q-mwpq, RHSA-2020:0553

## What is CVE-2019-11291?

CVE-2019-11291 is a low-severity cross-site scripting vulnerability in Broadcom Rabbitmq Server, published on 22 Nov 2019. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Pivotal RabbitMQ, 3.7 versions prior to v3.7.20 and 3.8 version prior to v3.8.1, and RabbitMQ for PCF, 1.16.x versions prior to 1.16.7 and 1.17.x versions prior to 1.17.4, contain two endpoints, federation and shovel, which do not properly sanitize user input. A remote authenticated malicious user with administrative access could craft a cross site scripting attack via the vhost or node name fields that could grant access to virtual hosts and policy management information.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2019-11291?

4 open source packages ship an affected version, including rabbit_common. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rabbit_common` | Hex | From 3.7.0 | 3.7.20 |
| `rabbit_common` | Hex | From 3.7.0 | 3.7.20 |
| `rabbit_common` | Hex | From 3.8.0 | 3.8.1 |
| `rabbit_common` | Hex | From 3.8.0 | 3.8.1 |
| `rabbitmq-server` | Red Hat:openstack:15::el8 | All versions | 0:3.7.23-2.el8ost |

Products: Broadcom Rabbitmq Server, Redhat Openstack, Vmware Rabbitmq.

## How do I fix CVE-2019-11291?

Upgrade rabbit_common to a fixed version for your release line: 3.7.20 or 3.8.1.

## Is CVE-2019-11291 being exploited?

There is no known exploitation of CVE-2019-11291 in the wild and no public exploit code.

## Other vulnerabilities in Broadcom Rabbitmq Server

- [CVE-2016-9877](https://insights.sbomify.com/CVE-2016-9877/): Auth bypass in Pivotal RabbitMQ 3.x before 3.5.8 and 3.6.x before 3.6.6; RabbitMQ for PCF 1.5.x before 1.5.20, 1.6.x before 1.6.12 and 1.7.x before 1.7.7 (critical 9.8)
- [CVE-2026-67404](https://insights.sbomify.com/CVE-2026-67404/): RabbitMQ: OAuth2 silent verify_none fallback for JWKS fetch (critical 9.2)
- [CVE-2026-67231](https://insights.sbomify.com/CVE-2026-67231/): RabbitMQ: Trust-store whitelist by Issuer+Serial only (critical 9.1)
- [CVE-2026-57219](https://insights.sbomify.com/CVE-2026-57219/): Information disclosure in rabbitmq-server (high 8.7)
- [CVE-2026-67236](https://insights.sbomify.com/CVE-2026-67236/): RabbitMQ: Plaintext username:password stored in an insecure cookie after successful POST /login (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-11291 and fix it if it is affected.

What it is: CVE-2019-11291 is a low-severity cross-site scripting vulnerability in Broadcom Rabbitmq Server, published on 22 Nov 2019. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-11291 in the wild and no public exploit code.

Affected packages and fixed versions:
- rabbit_common (Hex): affected from 3.7.0; fixed in 3.7.20
- rabbit_common (Hex): affected from 3.7.0; fixed in 3.7.20
- rabbit_common (Hex): affected from 3.8.0; fixed in 3.8.1
- rabbit_common (Hex): affected from 3.8.0; fixed in 3.8.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-11291/ (Markdown: https://insights.sbomify.com/CVE-2019-11291/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-11291
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-11291
- OSV: https://osv.dev/vulnerability/CVE-2019-11291

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-11291/
Summaries are generated and may contain mistakes; the official description above is the record.
