# CVE-2019-11324: Improper Certificate Validation in urllib3

> Attackers can bypass SSL certificate verification in urllib3 when custom CA certificates are specified, allowing man-in-the-middle attacks.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Apr 2019
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2019-11324, GHSA-mh33-7rrq-662w, MINI-gh64-fc88-2547, PYSEC-2019-133, ROOT-APP-PYPI-CVE-2019-11324, UBUNTU-CVE-2019-11324, openSUSE-SU-2024:11255-1

## What is CVE-2019-11324?

CVE-2019-11324 is a high-severity vulnerability in Canonical Ubuntu Linux, published on 18 Apr 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The urllib3 library before 1.24.2 for Python mishandles certain cases where the desired set of CA certificates is different from the OS store of CA certificates, which results in SSL connections succeeding in situations where a verification failure is the correct outcome. This is related to use of the ssl_context, ca_certs, or ca_certs_dir argument.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2019-11324?

3 open source packages ship an affected version, including urllib3. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `urllib3` | PyPI | All versions | 1.24.2 |
| `urllib3` | PyPI | All versions | 1.24.2 |
| `urllib3` | PyPI | All versions | 1.24.2 |

Products: Canonical Ubuntu Linux, Python Urllib3.

## How do I fix CVE-2019-11324?

Upgrade urllib3 to 1.24.2 or later.

## Is CVE-2019-11324 being exploited?

There is no known exploitation of CVE-2019-11324 in the wild and no public exploit code.

## Other vulnerabilities in Canonical Ubuntu Linux

- [CVE-2020-11651](https://insights.sbomify.com/CVE-2020-11651/): SaltStack Salt Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-7247](https://insights.sbomify.com/CVE-2020-7247/): OpenSMTPD Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2019-16928](https://insights.sbomify.com/CVE-2019-16928/): Exim Out-of-bounds Write (critical 9.8, exploited in the wild)
- [CVE-2018-6789](https://insights.sbomify.com/CVE-2018-6789/): Exim Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2015-2590](https://insights.sbomify.com/CVE-2015-2590/): Oracle Java SE and Java SE Embedded Remote Code Execution (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-11324 and fix it if it is affected.

What it is: CVE-2019-11324 is a high-severity vulnerability in Canonical Ubuntu Linux, published on 18 Apr 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-11324 in the wild and no public exploit code.

Affected packages and fixed versions:
- urllib3 (PyPI): affected all versions; fixed in 1.24.2
- urllib3 (PyPI): affected all versions; fixed in 1.24.2
- urllib3 (PyPI): affected all versions; fixed in 1.24.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-11324/ (Markdown: https://insights.sbomify.com/CVE-2019-11324/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-11324
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-11324
- OSV: https://osv.dev/vulnerability/CVE-2019-11324

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-11324/
Summaries are generated and may contain mistakes; the official description above is the record.
