{"answers":{"affected":"8 open source packages ship an affected version, including symfony/symfony and symfony/var-exporter. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-11325 in the wild and no public exploit code.","fix":"Upgrade symfony/symfony to a fixed version for your release line: 4.2.12 or 4.3.8.","what":"CVE-2019-11325 is a critical code injection vulnerability in Sensiolabs Symfony, published on 21 Nov 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-11325 and fix it if it is affected.\n\nWhat it is: CVE-2019-11325 is a critical code injection vulnerability in Sensiolabs Symfony, published on 21 Nov 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-11325 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- symfony/symfony (Packagist): affected from 4.2.0; fixed in 4.2.12\n- symfony/symfony (Packagist): affected from 4.2.0; fixed in 4.2.12\n- symfony/symfony (Packagist): affected from 4.3.0; fixed in 4.3.8\n- symfony/symfony (Packagist): affected from 4.3.0; fixed in 4.3.8\n- symfony/var-exporter (Packagist): affected from 4.2.0; fixed in 4.2.12\n- symfony/var-exporter (Packagist): affected from 4.2.0; fixed in 4.2.12\n- symfony/var-exporter (Packagist): affected from 4.3.0; fixed in 4.3.8\n- symfony/var-exporter (Packagist): affected from 4.3.0; fixed in 4.3.8\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-11325/ (Markdown: https://insights.sbomify.com/CVE-2019-11325/index.md)","id":"CVE-2019-11325","markdown":"https://insights.sbomify.com/CVE-2019-11325/index.md","name":"CVE-2019-11325","record":{"aliases":["DEBIAN-CVE-2019-11325","GHSA-w4rc-rx25-8m86"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Symfony PHP library","requires_auth":"none","summary":"Attackers can execute arbitrary PHP code via specially crafted strings due to incorrect escaping in the Symfony VarExport component.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"symfony","vendor":"sensiolabs"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-116","name":"Improper Encoding or Escaping of Output"}],"description":"An issue was discovered in Symfony before 4.2.12 and 4.3.x before 4.3.8. The VarExport component incorrectly escapes strings, allowing some specially crafted ones to escalate to execution of arbitrary PHP code. This is related to symfony/var-exporter.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Improper Input Validation in Symfony","id":"CVE-2019-11325","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"sensiolabs:symfony","products":["sensiolabs:symfony"],"type":"code_injection","year":"2019"},"n_packages":8,"n_references":4,"next":{"headline":"Auth bypass in n/a","id":"CVE-2019-11326"},"packages":[{"ecosystem":"Packagist","fixed":["4.2.12"],"introduced":["4.2.0"],"last_affected":[],"package":"symfony/symfony","purl":null,"source":"GHSA-w4rc-rx25-8m86"},{"ecosystem":"Packagist","fixed":["4.2.12"],"introduced":["4.2.0"],"last_affected":[],"package":"symfony/symfony","purl":"pkg:composer/symfony/symfony","source":"GHSA-w4rc-rx25-8m86"},{"ecosystem":"Packagist","fixed":["4.3.8"],"introduced":["4.3.0"],"last_affected":[],"package":"symfony/symfony","purl":null,"source":"GHSA-w4rc-rx25-8m86"},{"ecosystem":"Packagist","fixed":["4.3.8"],"introduced":["4.3.0"],"last_affected":[],"package":"symfony/symfony","purl":"pkg:composer/symfony/symfony","source":"GHSA-w4rc-rx25-8m86"},{"ecosystem":"Packagist","fixed":["4.2.12"],"introduced":["4.2.0"],"last_affected":[],"package":"symfony/var-exporter","purl":null,"source":"GHSA-w4rc-rx25-8m86"},{"ecosystem":"Packagist","fixed":["4.2.12"],"introduced":["4.2.0"],"last_affected":[],"package":"symfony/var-exporter","purl":"pkg:composer/symfony/var-exporter","source":"GHSA-w4rc-rx25-8m86"},{"ecosystem":"Packagist","fixed":["4.3.8"],"introduced":["4.3.0"],"last_affected":[],"package":"symfony/var-exporter","purl":null,"source":"GHSA-w4rc-rx25-8m86"},{"ecosystem":"Packagist","fixed":["4.3.8"],"introduced":["4.3.0"],"last_affected":[],"package":"symfony/var-exporter","purl":"pkg:composer/symfony/var-exporter","source":"GHSA-w4rc-rx25-8m86"}],"prev":{"headline":"Improper Certificate Validation in urllib3","id":"CVE-2019-11324"},"products":["n/a"],"published":"2019-11-21","related":[{"cvss_score":9.8,"headline":"Symfony Incorrect Access Control","id":"CVE-2017-11365","kev_date_added":null,"published":"2019-05-23"},{"cvss_score":9.8,"headline":"Invalid HTTP method overrides allow possible XSS or other attacks in Symfony","id":"CVE-2019-10913","kev_date_added":null,"published":"2019-05-16"},{"cvss_score":9.8,"headline":"Symfony Authentication Bypass","id":"CVE-2018-11407","kev_date_added":null,"published":"2018-06-13"},{"cvss_score":9.8,"headline":"Symfony Authentication Bypass","id":"CVE-2016-2403","kev_date_added":null,"published":"2017-02-07"},{"cvss_score":9.1,"headline":"Symfony: Identity Spoofing via Unanchored DN Regex in X509Authenticator","id":"CVE-2026-45063","kev_date_added":null,"published":"2026-07-14"},{"cvss_score":8.8,"headline":"Symfony: OidcTokenHandler Accepts JWTs Missing aud/iss/exp Claims","id":"CVE-2026-45069","kev_date_added":null,"published":"2026-07-14"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Attackers can execute arbitrary PHP code via specially crafted strings due to incorrect escaping in the Symfony VarExport component.","url":"https://insights.sbomify.com/CVE-2019-11325/"}