# CVE-2019-11325: Improper Input Validation in Symfony

> Attackers can execute arbitrary PHP code via specially crafted strings due to incorrect escaping in the Symfony VarExport component.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Nov 2019
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2019-11325, GHSA-w4rc-rx25-8m86

## What is CVE-2019-11325?

CVE-2019-11325 is a critical code injection vulnerability in Sensiolabs Symfony, published on 21 Nov 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in Symfony before 4.2.12 and 4.3.x before 4.3.8. The VarExport component incorrectly escapes strings, allowing some specially crafted ones to escalate to execution of arbitrary PHP code. This is related to symfony/var-exporter.

Weakness: CWE-116 (Improper Encoding or Escaping of Output)

## Which versions are affected by CVE-2019-11325?

8 open source packages ship an affected version, including symfony/symfony and symfony/var-exporter. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `symfony/symfony` | Packagist | From 4.2.0 | 4.2.12 |
| `symfony/symfony` | Packagist | From 4.2.0 | 4.2.12 |
| `symfony/symfony` | Packagist | From 4.3.0 | 4.3.8 |
| `symfony/symfony` | Packagist | From 4.3.0 | 4.3.8 |
| `symfony/var-exporter` | Packagist | From 4.2.0 | 4.2.12 |
| `symfony/var-exporter` | Packagist | From 4.2.0 | 4.2.12 |
| `symfony/var-exporter` | Packagist | From 4.3.0 | 4.3.8 |
| `symfony/var-exporter` | Packagist | From 4.3.0 | 4.3.8 |

Products: Sensiolabs Symfony.

## How do I fix CVE-2019-11325?

Upgrade symfony/symfony to a fixed version for your release line: 4.2.12 or 4.3.8.

## Is CVE-2019-11325 being exploited?

There is no known exploitation of CVE-2019-11325 in the wild and no public exploit code.

## Other vulnerabilities in Sensiolabs Symfony

- [CVE-2017-11365](https://insights.sbomify.com/CVE-2017-11365/): Symfony Incorrect Access Control (critical 9.8)
- [CVE-2019-10913](https://insights.sbomify.com/CVE-2019-10913/): Invalid HTTP method overrides allow possible XSS or other attacks in Symfony (critical 9.8)
- [CVE-2018-11407](https://insights.sbomify.com/CVE-2018-11407/): Symfony Authentication Bypass (critical 9.8)
- [CVE-2016-2403](https://insights.sbomify.com/CVE-2016-2403/): Symfony Authentication Bypass (critical 9.8)
- [CVE-2026-45063](https://insights.sbomify.com/CVE-2026-45063/): Symfony: Identity Spoofing via Unanchored DN Regex in X509Authenticator (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-11325 and fix it if it is affected.

What it is: CVE-2019-11325 is a critical code injection vulnerability in Sensiolabs Symfony, published on 21 Nov 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-11325 in the wild and no public exploit code.

Affected packages and fixed versions:
- symfony/symfony (Packagist): affected from 4.2.0; fixed in 4.2.12
- symfony/symfony (Packagist): affected from 4.2.0; fixed in 4.2.12
- symfony/symfony (Packagist): affected from 4.3.0; fixed in 4.3.8
- symfony/symfony (Packagist): affected from 4.3.0; fixed in 4.3.8
- symfony/var-exporter (Packagist): affected from 4.2.0; fixed in 4.2.12
- symfony/var-exporter (Packagist): affected from 4.2.0; fixed in 4.2.12
- symfony/var-exporter (Packagist): affected from 4.3.0; fixed in 4.3.8
- symfony/var-exporter (Packagist): affected from 4.3.0; fixed in 4.3.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-11325/ (Markdown: https://insights.sbomify.com/CVE-2019-11325/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-11325
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-11325
- OSV: https://osv.dev/vulnerability/CVE-2019-11325

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-11325/
Summaries are generated and may contain mistakes; the official description above is the record.
