# CVE-2019-11401: SiteServer CMS RCE via unsafe file upload

> Remote attackers can execute arbitrary code by uploading files with a specific extension that bypasses validation filters in SiteServer CMS.

- **Severity:** High 7.2 (`CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Apr 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-ff4w-8chr-w2x9

## What is CVE-2019-11401?

CVE-2019-11401 is a high-severity vulnerability in n/a, published on 21 Apr 2019. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

A issue was discovered in SiteServer CMS 6.9.0. It allows remote attackers to execute arbitrary code because an administrator can add the permitted file extension .aassp, which is converted to .asp because the "as" substring is deleted.

Weakness: CWE-434 (Unrestricted Upload of File with Dangerous Type)

## Which versions are affected by CVE-2019-11401?

2 open source packages ship an affected version, including sscms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sscms` | NuGet | All versions | 6.12 |
| `sscms` | NuGet | All versions | 6.12 |

Products: Siteserver Siteserver Cms.

## How do I fix CVE-2019-11401?

Upgrade sscms to 6.12 or later.

## Is CVE-2019-11401 being exploited?

There is no known exploitation of CVE-2019-11401 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-11401 and fix it if it is affected.

What it is: CVE-2019-11401 is a high-severity vulnerability in n/a, published on 21 Apr 2019. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-11401 in the wild and no public exploit code.

Affected packages and fixed versions:
- sscms (NuGet): affected all versions; fixed in 6.12
- sscms (NuGet): affected all versions; fixed in 6.12

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-11401/ (Markdown: https://insights.sbomify.com/CVE-2019-11401/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-11401
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-11401
- OSV: https://osv.dev/vulnerability/CVE-2019-11401

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-11401/
Summaries are generated and may contain mistakes; the official description above is the record.
