# CVE-2019-11404: Missing Encryption of Sensitive Data in arrow-kt Arrow

> Arrow library fetched build artifacts over HTTP, allowing MITM attackers to inject malicious code into the build process.

- **Severity:** High 8.1 (`CVSS:3.0/AC:H/AV:N/A:H/C:H/I:H/PR:N/S:U/UI:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Apr 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-rcj2-vvjx-87pm

## What is CVE-2019-11404?

CVE-2019-11404 is a high-severity vulnerability in n/a, published on 21 Apr 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

arrow-kt Arrow before 0.9.0 resolved Gradle build artifacts (for compiling and building the published JARs) over HTTP instead of HTTPS. Any of these dependent artifacts could have been maliciously compromised by an MITM attack.

Weakness: CWE-311 (Missing Encryption of Sensitive Data)

## Which versions are affected by CVE-2019-11404?

2 open source packages ship an affected version, including io.arrow-kt:arrow-ank-gradle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.arrow-kt:arrow-ank-gradle` | Maven | All versions | 0.9.0 |
| `io.arrow-kt:arrow-ank-gradle` | Maven | All versions | 0.9.0 |

Products: Arrow-Kt Arrow.

## How do I fix CVE-2019-11404?

Upgrade io.arrow-kt:arrow-ank-gradle to 0.9.0 or later.

## Is CVE-2019-11404 being exploited?

There is no known exploitation of CVE-2019-11404 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-11404 and fix it if it is affected.

What it is: CVE-2019-11404 is a high-severity vulnerability in n/a, published on 21 Apr 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-11404 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.arrow-kt:arrow-ank-gradle (Maven): affected all versions; fixed in 0.9.0
- io.arrow-kt:arrow-ank-gradle (Maven): affected all versions; fixed in 0.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-11404/ (Markdown: https://insights.sbomify.com/CVE-2019-11404/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-11404
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-11404
- OSV: https://osv.dev/vulnerability/CVE-2019-11404

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-11404/
Summaries are generated and may contain mistakes; the official description above is the record.
