# CVE-2019-11405: OpenAPI Tools OpenAPI Generator uses HTTP in various files

> OpenAPI Generator used insecure HTTP URLs for dependencies, potentially allowing attackers to intercept and modify build artifacts.

- **Severity:** High 8.1 (`CVSS:3.0/AC:H/AV:N/A:H/C:H/I:H/PR:N/S:U/UI:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Apr 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-27j5-2h6r-c9q2

## What is CVE-2019-11405?

CVE-2019-11405 is a high-severity vulnerability in n/a, published on 21 Apr 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

OpenAPI Tools OpenAPI Generator before 4.0.0-20190419.052012-560 uses http:// URLs in various build.gradle, build.gradle.mustache, and build.sbt files, which may have caused insecurely resolved dependencies.

Weakness: CWE-311 (Missing Encryption of Sensitive Data)

## Which versions are affected by CVE-2019-11405?

2 open source packages ship an affected version, including org.openapitools:openapi-generator. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.openapitools:openapi-generator` | Maven | All versions | 4.0.0-20190419.052012-560 |
| `org.openapitools:openapi-generator` | Maven | All versions | 4.0.0-20190419.052012-560 |

Products: Openapi-Generator Openapi Generator.

## How do I fix CVE-2019-11405?

Upgrade org.openapitools:openapi-generator to 4.0.0-20190419.052012-560 or later.

## Is CVE-2019-11405 being exploited?

There is no known exploitation of CVE-2019-11405 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2021-21428](https://insights.sbomify.com/CVE-2021-21428/): Creation of Temporary File in Directory with Insecure Permissions in the OpenAPI-Generator online generator (critical 9.3)
- [CVE-2023-27162](https://insights.sbomify.com/CVE-2023-27162/): OpenAPI Generator vulnerable to Server-Side Request Forgery (critical 9.1)
- [CVE-2021-21430](https://insights.sbomify.com/CVE-2021-21430/): Creation of Temporary File in Directory with Insecure Permissions in auto-generated Java, Scala code (medium 6.2)
- [CVE-2021-21429](https://insights.sbomify.com/CVE-2021-21429/): Creation of Temporary File in Directory with Insecure Permissions in the OpenAPI Generator Maven plugin (medium 4.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-11405 and fix it if it is affected.

What it is: CVE-2019-11405 is a high-severity vulnerability in n/a, published on 21 Apr 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-11405 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.openapitools:openapi-generator (Maven): affected all versions; fixed in 4.0.0-20190419.052012-560
- org.openapitools:openapi-generator (Maven): affected all versions; fixed in 4.0.0-20190419.052012-560

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-11405/ (Markdown: https://insights.sbomify.com/CVE-2019-11405/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-11405
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-11405
- OSV: https://osv.dev/vulnerability/CVE-2019-11405

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-11405/
Summaries are generated and may contain mistakes; the official description above is the record.
