{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-11460 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2019-11460 is a critical vulnerability in n/a, published on 22 Apr 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-11460 and fix it if it is affected.\n\nWhat it is: CVE-2019-11460 is a critical vulnerability in n/a, published on 22 Apr 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-11460 in the wild and no public exploit code.\n\nAffected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-11460/ (Markdown: https://insights.sbomify.com/CVE-2019-11460/index.md)","id":"CVE-2019-11460","markdown":"https://insights.sbomify.com/CVE-2019-11460/index.md","name":"CVE-2019-11460","record":{"aliases":["DEBIAN-CVE-2019-11460","GHSA-wqw3-2245-pjp7","SUSE-SU-2022:3837-1","UBUNTU-CVE-2019-11460","USN-3994-1","openSUSE-SU-2024:10796-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["privilege_escalation","code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"GNOME desktop library","requires_auth":"none","summary":"A compromised thumbnailer can escape the bubblewrap sandbox via TIOCSTI ioctl, enabling code execution and privilege escalation.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"gnome-desktop","vendor":"gnome"}],"cvss":{"score":9,"severity":"critical","source":"nvd","vector":"CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"An issue was discovered in GNOME gnome-desktop 3.26, 3.28, and 3.30 prior to 3.30.2.2, and 3.32 prior to 3.32.1.1. A compromised thumbnailer may escape the bubblewrap sandbox used to confine thumbnailers by using the TIOCSTI ioctl to push characters into the input buffer of the thumbnailer's controlling terminal, allowing an attacker to escape the sandbox if the thumbnailer has a controlling terminal. This is due to improper filtering of the TIOCSTI ioctl on 64-bit systems, similar to CVE-2019-10063.","ecosystems":["openSUSE:Leap 15.3","openSUSE:Leap 15.4","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Security feature bypass in n/a","id":"CVE-2019-11460","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"security_feature_bypass","year":"2019"},"n_packages":3,"n_references":5,"next":{"headline":"Security feature bypass in n/a","id":"CVE-2019-11461"},"packages":[{"ecosystem":"openSUSE:Leap 15.3","fixed":["3.26.2-150000.4.3.1"],"introduced":["0"],"last_affected":[],"package":"gnome-desktop","purl":"pkg:rpm/opensuse/gnome-desktop\u0026distro=openSUSE%20Leap%2015.3","source":"SUSE-SU-2022:3837-1"},{"ecosystem":"openSUSE:Leap 15.4","fixed":["3.26.2-150000.4.3.1"],"introduced":["0"],"last_affected":[],"package":"gnome-desktop","purl":"pkg:rpm/opensuse/gnome-desktop\u0026distro=openSUSE%20Leap%2015.4","source":"SUSE-SU-2022:3837-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["40.4-1.3"],"introduced":["0"],"last_affected":[],"package":"gnome-desktop","purl":"pkg:rpm/opensuse/gnome-desktop\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:10796-1"}],"prev":{"headline":"Memory corruption in n/a","id":"CVE-2019-11459"},"products":["n/a"],"published":"2019-04-22","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"A compromised thumbnailer can escape the bubblewrap sandbox via TIOCSTI ioctl, enabling code execution and privilege escalation.","url":"https://insights.sbomify.com/CVE-2019-11460/"}