{"answers":{"affected":"2 open source packages ship an affected version, including flarum/flarum. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-11514 in the wild and no public exploit code.","fix":"Upgrade flarum/flarum to 0.1.0-beta.8 or later.","what":"CVE-2019-11514 is a high-severity vulnerability in n/a, published on 25 Apr 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-11514 and fix it if it is affected.\n\nWhat it is: CVE-2019-11514 is a high-severity vulnerability in n/a, published on 25 Apr 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-11514 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- flarum/flarum (Packagist): affected all versions; fixed in 0.1.0-beta.8\n- flarum/flarum (Packagist): affected all versions; fixed in 0.1.0-beta.8\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-11514/ (Markdown: https://insights.sbomify.com/CVE-2019-11514/index.md)","id":"CVE-2019-11514","markdown":"https://insights.sbomify.com/CVE-2019-11514/index.md","name":"CVE-2019-11514","record":{"aliases":["GHSA-g6w5-439m-jhwv"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Flarum forum software","requires_auth":"none","summary":"Attackers can bypass email confirmation requirements due to improper token invalidation in Flarum forum software.","user_interaction":"not_required","vuln_class":"business_logic"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"flarum","vendor":"flarum"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N","version":"3.0"},"cwes":[{"id":"CWE-459","name":"Incomplete Cleanup"}],"description":"User/Command/ConfirmEmailHandler.php in Flarum before 0.1.0-beta.8 mishandles invalidation of user email tokens.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Flarum mishandles invalidation of user email tokens","id":"CVE-2019-11514","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"business_logic","year":"2019"},"n_packages":2,"n_references":2,"next":{"headline":"Path traversal in n/a","id":"CVE-2019-11515"},"packages":[{"ecosystem":"Packagist","fixed":["0.1.0-beta.8"],"introduced":["0"],"last_affected":[],"package":"flarum/flarum","purl":null,"source":"GHSA-g6w5-439m-jhwv"},{"ecosystem":"Packagist","fixed":["0.1.0-beta.8"],"introduced":["0"],"last_affected":[],"package":"flarum/flarum","purl":"pkg:composer/flarum/flarum","source":"GHSA-g6w5-439m-jhwv"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2019-11513"},"products":["n/a"],"published":"2019-04-25","related":[{"cvss_score":10,"headline":"XSS vulnerability with translator","id":"CVE-2021-32671","kev_date_added":null,"published":"2021-06-07"},{"cvss_score":9,"headline":"Cross site scripting vulnerability with discussion titles in flarum","id":"CVE-2022-41938","kev_date_added":null,"published":"2022-11-19"},{"cvss_score":8.8,"headline":"Cross-site request forgery in n/a","id":"CVE-2019-13183","kev_date_added":null,"published":"2019-07-07"},{"cvss_score":7.7,"headline":"Post mentions can be used to read any post on the forum without access control","id":"CVE-2023-22487","kev_date_added":null,"published":"2023-01-11"},{"cvss_score":7.1,"headline":"Server-Side Request Forgery via Avatar upload in flarum","id":"CVE-2023-40033","kev_date_added":null,"published":"2023-08-16"},{"cvss_score":6.8,"headline":"Flarum Vulnerable to Session Hijacking via Authoritative Subdomain Cookie Overwrite","id":"CVE-2025-27794","kev_date_added":null,"published":"2025-03-12"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Attackers can bypass email confirmation requirements due to improper token invalidation in Flarum forum software.","url":"https://insights.sbomify.com/CVE-2019-11514/"}