# CVE-2019-11514: Flarum mishandles invalidation of user email tokens

> Attackers can bypass email confirmation requirements due to improper token invalidation in Flarum forum software.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Apr 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-g6w5-439m-jhwv

## What is CVE-2019-11514?

CVE-2019-11514 is a high-severity vulnerability in n/a, published on 25 Apr 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

User/Command/ConfirmEmailHandler.php in Flarum before 0.1.0-beta.8 mishandles invalidation of user email tokens.

Weakness: CWE-459 (Incomplete Cleanup)

## Which versions are affected by CVE-2019-11514?

2 open source packages ship an affected version, including flarum/flarum. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `flarum/flarum` | Packagist | All versions | 0.1.0-beta.8 |
| `flarum/flarum` | Packagist | All versions | 0.1.0-beta.8 |

Products: Flarum Flarum.

## How do I fix CVE-2019-11514?

Upgrade flarum/flarum to 0.1.0-beta.8 or later.

## Is CVE-2019-11514 being exploited?

There is no known exploitation of CVE-2019-11514 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2021-32671](https://insights.sbomify.com/CVE-2021-32671/): XSS vulnerability with translator (critical 10.0)
- [CVE-2022-41938](https://insights.sbomify.com/CVE-2022-41938/): Cross site scripting vulnerability with discussion titles in flarum (critical 9.0)
- [CVE-2019-13183](https://insights.sbomify.com/CVE-2019-13183/): Cross-site request forgery in n/a (high 8.8)
- [CVE-2023-22487](https://insights.sbomify.com/CVE-2023-22487/): Post mentions can be used to read any post on the forum without access control (high 7.7)
- [CVE-2023-40033](https://insights.sbomify.com/CVE-2023-40033/): Server-Side Request Forgery via Avatar upload in flarum (high 7.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-11514 and fix it if it is affected.

What it is: CVE-2019-11514 is a high-severity vulnerability in n/a, published on 25 Apr 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-11514 in the wild and no public exploit code.

Affected packages and fixed versions:
- flarum/flarum (Packagist): affected all versions; fixed in 0.1.0-beta.8
- flarum/flarum (Packagist): affected all versions; fixed in 0.1.0-beta.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-11514/ (Markdown: https://insights.sbomify.com/CVE-2019-11514/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-11514
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-11514
- OSV: https://osv.dev/vulnerability/CVE-2019-11514

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-11514/
Summaries are generated and may contain mistakes; the official description above is the record.
