# CVE-2019-11580: Atlassian Crowd and Crowd Data Center Remote Code Execution

> Attackers can install arbitrary plugins via an exposed development plugin, leading to remote code execution on Atlassian Crowd instances.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Yes, since 3 Nov 2021 (CISA KEV), used in ransomware
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 3 Jun 2019
- **Updated:** 21 Oct 2025
- **Also known as:** GHSA-8977-4jwc-24g8

## What is CVE-2019-11580?

CVE-2019-11580 is a critical missing authorization vulnerability in Atlassian Crowd, published on 3 Jun 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Atlassian Crowd and Crowd Data Center had the pdkinstall development plugin incorrectly enabled in release builds. Attackers who can send unauthenticated or authenticated requests to a Crowd or Crowd Data Center instance can exploit this vulnerability to install arbitrary plugins, which permits remote code execution on systems running a vulnerable version of Crowd or Crowd Data Center. All versions of Crowd from version 2.1.0 before 3.0.5 (the fixed version for 3.0.x), from version 3.1.0 before 3.1.6 (the fixed version for 3.1.x), from version 3.2.0 before 3.2.8 (the fixed version for 3.2.x), from version 3.3.0 before 3.3.5 (the fixed version for 3.3.x), and from version 3.4.0 before 3.4.4 (the fixed version for 3.4.x) are affected by this vulnerability.

## Which versions are affected by CVE-2019-11580?

It affects 1 product.


Products: Atlassian Crowd.

## How do I fix CVE-2019-11580?

No fix has been published for CVE-2019-11580 yet. Limit exposure of the affected software until one is available. US federal agencies must fix it by 3 May 2022.

## Is CVE-2019-11580 being exploited?

Yes. Attackers have exploited CVE-2019-11580 in the wild since at least 3 Nov 2021, including in ransomware campaigns.

Public exploit code:

- CVE-2019-11580 Atlassian Crowd and Crowd Data Center RCE (github_poc): https://github.com/jas502n/CVE-2019-11580
- A CVE-2019-11580 shell (github_poc): https://github.com/shelld3v/CVE-2019-11580
- Atlassian Crowd pdkinstall Unauthenticated Plugin Upload RCE (metasploit)
- Atlassian Crowd and Crowd Data Center - Unauthenticated Remote Code Execution (nuclei): http/cves/2019/CVE-2019-11580.yaml

## Other vulnerabilities in Atlassian Crowd

- [CVE-2022-43782](https://insights.sbomify.com/CVE-2022-43782/): Auth bypass in Crowd Data Center (critical 9.8)
- [CVE-2016-6496](https://insights.sbomify.com/CVE-2016-6496/): Deserialization in n/a (critical 9.8)
- [CVE-2017-18105](https://insights.sbomify.com/CVE-2017-18105/): Auth bypass in Crowd (high 8.1)
- [CVE-2018-20238](https://insights.sbomify.com/CVE-2018-20238/): Auth bypass in Crowd (high 8.1)
- [CVE-2023-22521](https://insights.sbomify.com/CVE-2023-22521/): Code injection in Crowd Data Center (high 8.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-11580 and fix it if it is affected.

What it is: CVE-2019-11580 is a critical missing authorization vulnerability in Atlassian Crowd, published on 3 Jun 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: Yes. Attackers have exploited CVE-2019-11580 in the wild since at least 3 Nov 2021, including in ransomware campaigns.

Affected product: Atlassian Crowd. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-11580/ (Markdown: https://insights.sbomify.com/CVE-2019-11580/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-11580
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-11580
- OSV: https://osv.dev/vulnerability/CVE-2019-11580

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-11580/
Summaries are generated and may contain mistakes; the official description above is the record.
