# CVE-2019-11777: Improper Handling of Exceptional Conditions and Origin Validation Error in Eclipse Paho Java client library

> Attackers can impersonate MQTT servers by bypassing TLS hostname verification, leading to data interception or injection.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Sep 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-63qc-p2x4-9fgf

## What is CVE-2019-11777?

CVE-2019-11777 is a high-severity vulnerability in The Eclipse Foundation Eclipse Paho, published on 11 Sep 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In the Eclipse Paho Java client library version 1.2.0, when connecting to an MQTT server using TLS and setting a host name verifier, the result of that verification is not checked. This could allow one MQTT server to impersonate another and provide the client library with incorrect information.

Weakness: CWE-755 (Improper Handling of Exceptional Conditions), CWE-346 (Origin Validation Error)

## Which versions are affected by CVE-2019-11777?

2 open source packages ship an affected version, including org.eclipse.paho:org.eclipse.paho.client.mqttv3. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.eclipse.paho:org.eclipse.paho.client.mqttv3` | Maven | All versions | 1.2.1 |
| `org.eclipse.paho:org.eclipse.paho.client.mqttv3` | Maven | All versions | 1.2.1 |

Products: Eclipse Paho Java Client.

## How do I fix CVE-2019-11777?

Upgrade org.eclipse.paho:org.eclipse.paho.client.mqttv3 to 1.2.1 or later.

## Is CVE-2019-11777 being exploited?

There is no known exploitation of CVE-2019-11777 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-11777 and fix it if it is affected.

What it is: CVE-2019-11777 is a high-severity vulnerability in The Eclipse Foundation Eclipse Paho, published on 11 Sep 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-11777 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.eclipse.paho:org.eclipse.paho.client.mqttv3 (Maven): affected all versions; fixed in 1.2.1
- org.eclipse.paho:org.eclipse.paho.client.mqttv3 (Maven): affected all versions; fixed in 1.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-11777/ (Markdown: https://insights.sbomify.com/CVE-2019-11777/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-11777
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-11777
- OSV: https://osv.dev/vulnerability/CVE-2019-11777

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-11777/
Summaries are generated and may contain mistakes; the official description above is the record.
