# CVE-2019-11808: Use of Cryptographically Weak Pseudo-Random Number Generator (PRNG) in Ratpack

> Attackers can predict session IDs due to weak random number generation, potentially leading to account takeover.

- **Severity:** Low 3.7 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 May 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-54mg-vgrp-mwx9

## What is CVE-2019-11808?

CVE-2019-11808 is a low-severity vulnerability in n/a, published on 7 May 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Ratpack versions before 1.6.1 generate a session ID using a cryptographically weak PRNG in the JDK's ThreadLocalRandom. This means that if an attacker can determine a small window for the server start time and obtain a session ID value, they can theoretically determine the sequence of session IDs.

Weakness: CWE-338 (Use of Cryptographically Weak Pseudo-Random Number Generator (PRNG))

## Which versions are affected by CVE-2019-11808?

6 open source packages ship an affected version, including io.ratpack:ratpack-groovy, io.ratpack:ratpack-java and io.ratpack:ratpack-session. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.ratpack:ratpack-groovy` | Maven | All versions | 1.6.1 |
| `io.ratpack:ratpack-groovy` | Maven | All versions | 1.6.1 |
| `io.ratpack:ratpack-java` | Maven | All versions | 1.6.1 |
| `io.ratpack:ratpack-java` | Maven | All versions | 1.6.1 |
| `io.ratpack:ratpack-session` | Maven | All versions | 1.6.1 |
| `io.ratpack:ratpack-session` | Maven | All versions | 1.6.1 |

Products: Ratpack Project Ratpack.

## How do I fix CVE-2019-11808?

Upgrade io.ratpack:ratpack-groovy to 1.6.1 or later.

## Is CVE-2019-11808 being exploited?

There is no known exploitation of CVE-2019-11808 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2021-29485](https://insights.sbomify.com/CVE-2021-29485/): Remote Code Execution Vulnerability in Session Storage (critical 9.9)
- [CVE-2019-17513](https://insights.sbomify.com/CVE-2019-17513/): io.ratpack:ratpack-core vulnerable to Improper Neutralization of Special Elements in Output ('Injection') (high 7.5)
- [CVE-2021-29479](https://insights.sbomify.com/CVE-2021-29479/): Cached redirect poisoning via X-Forwarded-Host header (high 7.0)
- [CVE-2021-29481](https://insights.sbomify.com/CVE-2021-29481/): Client side sessions should not allow unencrypted storage (medium 6.5)
- [CVE-2021-29480](https://insights.sbomify.com/CVE-2021-29480/): Default client side session signing key is highly predictable (medium 4.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-11808 and fix it if it is affected.

What it is: CVE-2019-11808 is a low-severity vulnerability in n/a, published on 7 May 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-11808 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.ratpack:ratpack-groovy (Maven): affected all versions; fixed in 1.6.1
- io.ratpack:ratpack-groovy (Maven): affected all versions; fixed in 1.6.1
- io.ratpack:ratpack-java (Maven): affected all versions; fixed in 1.6.1
- io.ratpack:ratpack-java (Maven): affected all versions; fixed in 1.6.1
- io.ratpack:ratpack-session (Maven): affected all versions; fixed in 1.6.1
- io.ratpack:ratpack-session (Maven): affected all versions; fixed in 1.6.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-11808/ (Markdown: https://insights.sbomify.com/CVE-2019-11808/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-11808
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-11808
- OSV: https://osv.dev/vulnerability/CVE-2019-11808

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-11808/
Summaries are generated and may contain mistakes; the official description above is the record.
