CVE-2019-11818 Alkacon OpenCMS XSS via New User module

Medium 6.1 Published Updated

Stored XSS in OpenCMS allows attackers to inject JavaScript via user profile fields, potentially leading to session hijacking or malicious actions.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2019-11818?

CVE-2019-11818 is a medium-severity cross-site scripting vulnerability in n/a, published on 8 May 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Alkacon OpenCMS v10.5.4 and before is affected by stored cross site scripting (XSS) in the module New User (/opencms/system/workplace/admin/accounts/user_new.jsp). This allows an attacker to insert arbitrary JavaScript as user input (First Name or Last Name), which will be executed whenever the affected snippet is loaded.

Weakness: CWE-79

Which versions are affected by CVE-2019-11818?

2 open source packages ship an affected version, including org.opencms:opencms-core. It affects 1 product.

PackageAffectedFixed in
org.opencms:opencms-core MavenAll versions11.0.0
org.opencms:opencms-core MavenAll versions11.0.0

Products include Alkacon Opencms.

How do I fix CVE-2019-11818?

Upgrade org.opencms:opencms-core to 11.0.0 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2019-11818 being exploited?

There is no known exploitation of CVE-2019-11818 in the wild and no public exploit code.

Sources

Also known as GHSA-c8j6-gqq8-4prj.

Is CVE-2019-11818 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free