# CVE-2019-11818: Alkacon OpenCMS XSS via New User module

> Stored XSS in OpenCMS allows attackers to inject JavaScript via user profile fields, potentially leading to session hijacking or malicious actions.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 8 May 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-c8j6-gqq8-4prj

## What is CVE-2019-11818?

CVE-2019-11818 is a medium-severity cross-site scripting vulnerability in n/a, published on 8 May 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Alkacon OpenCMS v10.5.4 and before is affected by stored cross site scripting (XSS) in the module New User (/opencms/system/workplace/admin/accounts/user_new.jsp). This allows an attacker to insert arbitrary JavaScript as user input (First Name or Last Name), which will be executed whenever the affected snippet is loaded.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2019-11818?

2 open source packages ship an affected version, including org.opencms:opencms-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.opencms:opencms-core` | Maven | All versions | 11.0.0 |
| `org.opencms:opencms-core` | Maven | All versions | 11.0.0 |

Products: Alkacon Opencms.

## How do I fix CVE-2019-11818?

Upgrade org.opencms:opencms-core to 11.0.0 or later.

## Is CVE-2019-11818 being exploited?

There is no known exploitation of CVE-2019-11818 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2018-8811](https://insights.sbomify.com/CVE-2018-8811/): Cross-site request forgery in n/a (high 8.8)
- [CVE-2019-11819](https://insights.sbomify.com/CVE-2019-11819/): Alkacon OpenCMS CSV Injection via New User module (high 7.8)
- [CVE-2005-4475](https://insights.sbomify.com/CVE-2005-4475/): Cross-site scripting in n/a (medium 6.8)
- [CVE-2024-42699](https://insights.sbomify.com/CVE-2024-42699/): OpenCMS Cross-Site Scripting vulnerability (medium 6.5)
- [CVE-2021-3312](https://insights.sbomify.com/CVE-2021-3312/): XML External Entity Reference in org.opencms:opencms-core (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-11818 and fix it if it is affected.

What it is: CVE-2019-11818 is a medium-severity cross-site scripting vulnerability in n/a, published on 8 May 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-11818 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.opencms:opencms-core (Maven): affected all versions; fixed in 11.0.0
- org.opencms:opencms-core (Maven): affected all versions; fixed in 11.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-11818/ (Markdown: https://insights.sbomify.com/CVE-2019-11818/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-11818
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-11818
- OSV: https://osv.dev/vulnerability/CVE-2019-11818

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-11818/
Summaries are generated and may contain mistakes; the official description above is the record.
