# CVE-2019-11830: PharStreamWrapper for Typo3 unsafe deserialization vulnerability

> Attackers can bypass deserialization protection mechanisms in the phar-stream-wrapper library by exploiting mishandled Phar stub parsing.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 May 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-3hxw-g85p-qgxm

## What is CVE-2019-11830?

CVE-2019-11830 is a critical unsafe deserialization vulnerability in n/a, published on 9 May 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

PharMetaDataInterceptor in the PharStreamWrapper (aka phar-stream-wrapper) package 2.x before 2.1.1 and 3.x before 3.1.1 for TYPO3 mishandles Phar stub parsing, which allows attackers to bypass a deserialization protection mechanism.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2019-11830?

4 open source packages ship an affected version, including typo3/phar-stream-wrapper. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `typo3/phar-stream-wrapper` | Packagist | From 2.0.0 | 2.1.1 |
| `typo3/phar-stream-wrapper` | Packagist | From 2.0.0 | 2.1.1 |
| `typo3/phar-stream-wrapper` | Packagist | From 3.0.0 | 3.1.1 |
| `typo3/phar-stream-wrapper` | Packagist | From 3.0.0 | 3.1.1 |

Products: Typo3 Pharstreamwrapper.

## How do I fix CVE-2019-11830?

Upgrade typo3/phar-stream-wrapper to a fixed version for your release line: 2.1.1 or 3.1.1.

## Is CVE-2019-11830 being exploited?

There is no known exploitation of CVE-2019-11830 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-11830 and fix it if it is affected.

What it is: CVE-2019-11830 is a critical unsafe deserialization vulnerability in n/a, published on 9 May 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-11830 in the wild and no public exploit code.

Affected packages and fixed versions:
- typo3/phar-stream-wrapper (Packagist): affected from 2.0.0; fixed in 2.1.1
- typo3/phar-stream-wrapper (Packagist): affected from 2.0.0; fixed in 2.1.1
- typo3/phar-stream-wrapper (Packagist): affected from 3.0.0; fixed in 3.1.1
- typo3/phar-stream-wrapper (Packagist): affected from 3.0.0; fixed in 3.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-11830/ (Markdown: https://insights.sbomify.com/CVE-2019-11830/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-11830
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-11830
- OSV: https://osv.dev/vulnerability/CVE-2019-11830

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-11830/
Summaries are generated and may contain mistakes; the official description above is the record.
