CVE-2019-11831 Directory Traversal in typo3/phar-stream-wrapper
Attackers can bypass deserialization protections in TYPO3 via directory traversal in the phar-stream-wrapper library, potentially leading to further exploitation.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2019-11831?
CVE-2019-11831 is a critical path traversal vulnerability in Debian Debian Linux, published on 9 May 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
The PharStreamWrapper (aka phar-stream-wrapper) package 2.x before 2.1.1 and 3.x before 3.1.1 for TYPO3 does not prevent directory traversal, which allows attackers to bypass a deserialization protection mechanism, as demonstrated by a phar:///path/bad.phar/../good.phar URL.
Which versions are affected by CVE-2019-11831?
17 open source packages ship an affected version, including drupal/core, drupal/drupal and typo3/phar-stream-wrapper. It affects 5 products.
| Package | Affected | Fixed in |
|---|---|---|
drupal/core Packagist | From 7.0.0 | 7.67.0 |
drupal/core Packagist | From 7.0.0 | 7.67.0 |
drupal/core Packagist | From 8.0.0 | 8.6.16, 8.7.1 |
drupal/core Packagist | From 8.0.0 | 8.6.16 |
drupal/core Packagist | From 8.0.0 | 8.6.16 |
drupal/core Packagist | From 8.7.0 | 8.7.1 |
11 more packages
drupal/core Packagist | From 8.7.0 | 8.7.1 |
drupal/drupal Packagist | From 7.0.0 | 7.67.0 |
drupal/drupal Packagist | From 7.0.0 | 7.67.0 |
drupal/drupal Packagist | From 8.0.0 | 8.6.16 |
drupal/drupal Packagist | From 8.0.0 | 8.6.16 |
drupal/drupal Packagist | From 8.7.0 | 8.7.1 |
drupal/drupal Packagist | From 8.7.0 | 8.7.1 |
typo3/phar-stream-wrapper Packagist | From 2.0.0 | 2.1.1 |
typo3/phar-stream-wrapper Packagist | From 2.0.0 | 2.1.1 |
typo3/phar-stream-wrapper Packagist | From 3.0.0 | 3.1.1 |
typo3/phar-stream-wrapper Packagist | From 3.0.0 | 3.1.1 |
Products include Debian Debian Linux, Drupal Drupal, Fedoraproject Fedora, Joomla Joomla\!, Typo3 Pharstreamwrapper.
How do I fix CVE-2019-11831?
Upgrade drupal/core to a fixed version for your release line: 7.67.0, 8.6.16 or 8.7.1.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is CVE-2019-11831 being exploited?
There is no known exploitation of CVE-2019-11831 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as DRUPAL-CORE-2019-007, DSA-4445-1, GHSA-xv7v-rf6g-xwrc, UBUNTU-CVE-2019-11831.