{"answers":{"affected":"2 open source packages ship an affected version, including prestashop/prestashop. It affects 2 products.","exploited":"There is no known exploitation of CVE-2019-11876 in the wild and no public exploit code.","fix":"Upgrade prestashop/prestashop to 1.7.6.0 or later.","what":"CVE-2019-11876 is a medium-severity cross-site scripting vulnerability in Drupal Drupal, published on 24 May 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2019-11876 and fix it if it is affected.\n\nWhat it is: CVE-2019-11876 is a medium-severity cross-site scripting vulnerability in Drupal Drupal, published on 24 May 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2019-11876 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- prestashop/prestashop (Packagist): affected from 1.7.5.2; fixed in 1.7.6.0\n- prestashop/prestashop (Packagist): affected from 1.7.5.2; fixed in 1.7.6.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-11876/ (Markdown: https://insights.sbomify.com/CVE-2019-11876/index.md)","id":"CVE-2019-11876","markdown":"https://insights.sbomify.com/CVE-2019-11876/index.md","name":"CVE-2019-11876","record":{"aliases":["GHSA-6grv-hw8g-4gfm"],"analysis":{"component_type":"web_application","fix_type":"patch","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"PrestaShop e-commerce","requires_auth":"none","summary":"Reflected XSS in PrestaShop installation script allows attackers to execute scripts if users follow setup steps and click a malicious link.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"drupal","vendor":"drupal"},{"product":"prestashop","vendor":"prestashop"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"In PrestaShop 1.7.5.2, the shop_country parameter in the install/index.php installation script/component is affected by Reflected XSS. Exploitation by a malicious actor requires the user to follow the initial stages of the setup (accepting terms and conditions) before executing the malicious link.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"PrestaShop Cross-site Scripting vulnerability","id":"CVE-2019-11876","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"drupal:drupal","products":["drupal:drupal","prestashop:prestashop"],"type":"xss","year":"2019"},"n_packages":2,"n_references":2,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2019-11877"},"packages":[{"ecosystem":"Packagist","fixed":["1.7.6.0"],"introduced":["1.7.5.2"],"last_affected":[],"package":"prestashop/prestashop","purl":null,"source":"GHSA-6grv-hw8g-4gfm"},{"ecosystem":"Packagist","fixed":["1.7.6.0"],"introduced":["1.7.5.2"],"last_affected":[],"package":"prestashop/prestashop","purl":"pkg:composer/prestashop/prestashop","source":"GHSA-6grv-hw8g-4gfm"}],"prev":{"headline":"Missing authorization in n/a","id":"CVE-2019-11875"},"products":["n/a"],"published":"2019-05-24","related":[{"cvss_score":9.8,"headline":"Drupal Core SQL Injection","id":"CVE-2026-9082","kev_date_added":"2026-05-22","published":"2026-05-20"},{"cvss_score":8.8,"headline":"Drupal core Un-restricted Upload of File","id":"CVE-2020-13671","kev_date_added":"2022-01-18","published":"2020-11-20"},{"cvss_score":8.1,"headline":"Drupal Core Remote Code Execution","id":"CVE-2019-6340","kev_date_added":"2022-03-25","published":"2019-02-21"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2009-3352","kev_date_added":null,"published":"2009-09-24"},{"cvss_score":9.8,"headline":"Drupal core - Less critical - Gadget chain - SA-CORE-2024-006","id":"CVE-2024-55636","kev_date_added":null,"published":"2024-12-09"},{"cvss_score":9.8,"headline":"Drupal core - Moderately critical - Gadget chain - SA-CORE-2024-007","id":"CVE-2024-55637","kev_date_added":null,"published":"2024-12-09"},{"cvss_score":9.8,"headline":"Drupal core - Moderately critical - Gadget chain - SA-CORE-2024-008","id":"CVE-2024-55638","kev_date_added":null,"published":"2024-12-09"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Reflected XSS in PrestaShop installation script allows attackers to execute scripts if users follow setup steps and click a malicious link.","url":"https://insights.sbomify.com/CVE-2019-11876/"}