# CVE-2019-11876: PrestaShop Cross-site Scripting vulnerability

> Reflected XSS in PrestaShop installation script allows attackers to execute scripts if users follow setup steps and click a malicious link.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 May 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-6grv-hw8g-4gfm

## What is CVE-2019-11876?

CVE-2019-11876 is a medium-severity cross-site scripting vulnerability in Drupal Drupal, published on 24 May 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

In PrestaShop 1.7.5.2, the shop_country parameter in the install/index.php installation script/component is affected by Reflected XSS. Exploitation by a malicious actor requires the user to follow the initial stages of the setup (accepting terms and conditions) before executing the malicious link.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2019-11876?

2 open source packages ship an affected version, including prestashop/prestashop. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `prestashop/prestashop` | Packagist | From 1.7.5.2 | 1.7.6.0 |
| `prestashop/prestashop` | Packagist | From 1.7.5.2 | 1.7.6.0 |

Products: Drupal Drupal, Prestashop Prestashop.

## How do I fix CVE-2019-11876?

Upgrade prestashop/prestashop to 1.7.6.0 or later.

## Is CVE-2019-11876 being exploited?

There is no known exploitation of CVE-2019-11876 in the wild and no public exploit code.

## Other vulnerabilities in Drupal Drupal

- [CVE-2026-9082](https://insights.sbomify.com/CVE-2026-9082/): Drupal Core SQL Injection (critical 9.8, exploited in the wild)
- [CVE-2020-13671](https://insights.sbomify.com/CVE-2020-13671/): Drupal core Un-restricted Upload of File (high 8.8, exploited in the wild)
- [CVE-2019-6340](https://insights.sbomify.com/CVE-2019-6340/): Drupal Core Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2009-3352](https://insights.sbomify.com/CVE-2009-3352/): Other in n/a (critical 10.0)
- [CVE-2024-55636](https://insights.sbomify.com/CVE-2024-55636/): Drupal core - Less critical - Gadget chain - SA-CORE-2024-006 (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-11876 and fix it if it is affected.

What it is: CVE-2019-11876 is a medium-severity cross-site scripting vulnerability in Drupal Drupal, published on 24 May 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-11876 in the wild and no public exploit code.

Affected packages and fixed versions:
- prestashop/prestashop (Packagist): affected from 1.7.5.2; fixed in 1.7.6.0
- prestashop/prestashop (Packagist): affected from 1.7.5.2; fixed in 1.7.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-11876/ (Markdown: https://insights.sbomify.com/CVE-2019-11876/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-11876
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-11876
- OSV: https://osv.dev/vulnerability/CVE-2019-11876

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-11876/
Summaries are generated and may contain mistakes; the official description above is the record.
