# CVE-2019-11990: Auth bypass in HPE IOT and GCP

> Unauthorized remote access allows attackers to view sensitive data in HPE UIoT, requiring users to upgrade to patched versions.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 19 Jul 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-2rrf-398j-6q9g

## What is CVE-2019-11990?

CVE-2019-11990 is a high-severity authentication bypass vulnerability in HPE IOT and GCP, published on 19 Jul 2019. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Security vulnerabilities in HPE UIoT versions 1.6, 1.5, 1.4.2, 1.4.1, 1.4.0, and 1.2.4.2 could allow unauthorized remote access and access to sensitive data. HPE has addressed this issue in HPE UIoT: * For customers with release UIoT 1.6, fixes are made available with 1.6 RP603 * For customers with release UIoT 1.5, fixes are made available with 1.5 RP503 HF3 * For customers with release older than 1.5, such as 1.4.0, 1.4.1, 1.4.2 and 1.2.4.2, the resolution will be to upgrade to 1.5 RP503 HF3 or 1.6 RP603 Customers are requested to upgrade to the updated versions or contact HPE support for further assistance.

## Which versions are affected by CVE-2019-11990?

It affects 1 product.


Products: Hp Universal Internet of Things.

## How do I fix CVE-2019-11990?

No fix has been published for CVE-2019-11990 yet. Limit exposure of the affected software until one is available.

## Is CVE-2019-11990 being exploited?

There is no known exploitation of CVE-2019-11990 in the wild and no public exploit code.

## Other vulnerabilities in HPE IOT and GCP

- [CVE-2019-11995](https://insights.sbomify.com/CVE-2019-11995/): Auth bypass in HPE IOT + GCP (high 7.5)
- [CVE-2018-7111](https://insights.sbomify.com/CVE-2018-7111/): Missing authorization in HPE UIoT (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-11990 and fix it if it is affected.

What it is: CVE-2019-11990 is a high-severity authentication bypass vulnerability in HPE IOT and GCP, published on 19 Jul 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-11990 in the wild and no public exploit code.

Affected product: HPE IOT and GCP. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-11990/ (Markdown: https://insights.sbomify.com/CVE-2019-11990/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-11990
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-11990
- OSV: https://osv.dev/vulnerability/CVE-2019-11990

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-11990/
Summaries are generated and may contain mistakes; the official description above is the record.
